Best answer

Firebase/Zapier not finding recent records

  • 7 March 2021
  • 5 replies

We have a Zapier > Slack task and it’s recently stopped finding the most recent firebase records. It seems Zapier is pulling through records based on key order (alphabetical) rather than chronologically. I’ve found documentation on “calling setWithPriority and using Firebase.ServerValue.TIMESTAMP to order by timestamp.” ( I’m not sure how to do this in Zapier?

The Firebase Realtime Database has `users` with pushed objects (around 3000 objects/users at the moment):


This is the current set up of Zapier (although I’ve tried all sorts of options)…


When I run the test trigger all I get is…


None of the the most recent records come through. Based on the keys I’m seeing from the records it looks like Zapier is only pulling in alphabetically rather than chronologically. As you’ll see above, each record inside `users` has a `lastActive` property which is a standard epoc timestamp. I’ve tried to add `lastActive` to the Zapier `order` field but that doesn’t seem to work. Any ideas what we’re doing wrong?


Best answer by Paolo 4 June 2021, 06:58

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +9

Hi @nglenister,

It should definitely get the records from “lastActive” when you selected that in the “order” field. Do you try with “Top of The Results” in the “Location of Newest Objects” field?

I’d suggest you try out things a bit more, maybe create a new record in Firebase and see if it works/shows up, if this doesn’t resolve contact support here:


Thanks @robschmidt , I’ve messaged support. Will update again here if a solution is found

Userlevel 7
Badge +10

Just checking in to see if you still need help with this? 

Userlevel 3
Badge +5

Hey @nglenister, it looks like you reached out to our support team about this, and my colleague Wes replied to you. Just wanted to paste their response here for anyone else experiencing the same issue:


I'm wondering if having lastActive and limit to last selected at the same time is causing a problem.

Would you mind:
- Clearing the location of the newest objects field
- Adding a new object that you would expect to see in this Zap
- Loading a new sample to see if that works

If that doesn't work, please let me know and I'd be glad to take another look at what's happening.

Userlevel 1

Having the same problem. Would really help to have clearer documentation here.