Best answer

Facebook Messenger to Zapier integration

Userlevel 2

Hi, @nicksimard 

 I have a requirement .. when a any user goes to my Facebook page and sends a message thru messenger… I want to capture the message details like user first name, last name, email etc. and create a contact in Salesforce using Zapper workflow. But when I am trying to connect to messenger app in Zappier.. I am getting the following error message. What should I do to fix the issue please ? Any help will be appreciated. Thanks so much.


Error Message#


(#100) Object does not exist, cannot be loaded due to missing permission or reviewable feature, or does not support this operation. This endpoint requires the 'pages_read_engagement' permission or the 'Page Public Content Access' feature or the 'P... Hide details


(#100) Object does not exist, cannot be loaded due to missing permission or reviewable feature, or does not support this operation. This endpoint requires the 'pages_read_engagement' permission or the 'Page Public Content Access' feature or the 'Page Public Metadata Access' feature.. Refer to, and details.


Best answer by SamB 17 September 2021, 11:55

View original

267 replies

Userlevel 7
Badge +12

Hi @Jim Kikken, I’ve added you as an affected user on the issue report, thank you!

Same issue.

Userlevel 7
Badge +12

HI @lugandcarrie!


Thanks for letting us know that you’re having the same issue, I’ve added you as an affected user on the bug. This lets the team know how many people are affected by it and we’ll send you an email when we have an update. Thanks!

I am a user of Pro plan.

I am really upset about this issue is pending for so long.

Our company can’t afford waiting forever.

I am starting to look for an alternative today and make a plan of leaving.

Userlevel 7
Badge +11

Hi @Andrew777,

I see comments on our end that a fix has been deployed, which *should* address the issue. Can you confirm whether it’s working for you now? We’ve also reached out to other Zapier users to get confirmation but as far as I can see, we haven’t heard back yet. 

Userlevel 1

I just checked, same issue is still there!

I had a fix for another issue that might be related below but that DID NOT WORK for Zapier.

I had an issue with business inbox not opening up in desktop and the fix below is worked for me 

Do the following:
1. Open page
2. Go on Facebook Business Suite for your page.
3. Click on Settings
4. Click on People
- your name will show as admin
5. Click on "Assign assets and set permissions" - next to your name
6. Enable ALL permissions
7. Click SAVE!

Userlevel 7
Badge +11

Hey @GuyMayer, thanks for sharing that fix for the other issue. :)

Sorry that you’re running into the same issue despite the fix that was implemented. Can I ask whether you’ve tried reconnecting since the fix was deployed? 

I ask as we’ve since had some reports of Zaps working again after carrying out the following steps:

  1. Reconnect to Facebook Messenger from Zapier here:
  2. Make sure you have permissions for the Page where you want to see/add new messages
  3. Then test your Zap’s trigger to see if it goes through without error

Can you please give that a try and let us know if that solves it?

Userlevel 1

GOOD NEWS!  reconnecting worked.  I deleted the old connections and made a new one.

ALSO I have 2 business pages I made sure I only connected as 1 page.

Thank you!


Deleting and re-connecting seemed to do the trick for me insofar as the ‘object not found’ error has good, but I’m still only getting the dummy ‘Zap Zaplar’ message when I try to load samples - no real messages. Is this a related issue or am I doing something else wrong?


Userlevel 7
Badge +11

Hey @wkidger,

I’m so glad to hear that reconnecting did the trick for you too! :)

It sounds like you might be pulling in sample data so you’ll want to check out the following guide to find out more about how to change your sample: Change the test data in your Zap trigger

If that doesn’t do the trick I’d recommend reaching out to our Support Team to investigate further! 

Is zapier not able to connect Fb messenger to any apps? (Not just salesforce)

Userlevel 7
Badge +11

Hey @Abcxytz1234,

We’ve had reports that reconnecting the affected Facebook Messenger accounts solved the issue being discussed in this thread. So I’d recommend giving that a try to see if that helps allow your Zaps to connect with other apps.

And if you’re still having trouble it may be best to reach out to our Support team about this as they’ll be better able to dig into the logs for your Zaps to see what might be causing issues. The best way to reach them is via the Get Help form. :)

Has bug been fixed? I’m still getting below error.


Userlevel 7
Badge +11

Thanks for letting us know, @PH TupperShop Resource!

Are you still getting that error after reconnecting the Facebook Messenger account?

I ask as the bug report for this issue is now closed, so if that’s the case I’d recommend contacting our Support Team about this. They’ll be able to investigate further and get the bug report reopened if necessary. 

Userlevel 1

Awesome - works for me now after reconnecting to FB. Thank you. 


Is this issue back for some reason ?

We used to have a Messenge > Slack integration running and I cannot set it live again.

I have tried recreating it from the start and reconnecting FB but nothing will do.

Below that same error message that was gone but is back.

Please help



Userlevel 7
Badge +9

Oh no, @Pierre-Hugo! I’m so sorry to hear that!

This is still marked as closed but if you’re running into this still I might recommend contacting our friends in support to dig into this a bit more with you.