Question

Error wordpress REST API return 404

  • 7 October 2020
  • 3 replies
  • 658 views

Good morning, I am trying to connect Zapier with my website in Wordpress.

The Zapier plugin is installed and activated.

 

I try to make the normal connection through Zapier.

 

And I get this message

 

If I look at the server logs I get that a connection has been attempted with a 404 error result.

[05/Oct/2020:11:45:09 +0200] "POST /wp-json/zapier/v1/token HTTP/1.1" 404 149 "-" "Zapier"

 

However if I make this connection it works, response 200, therefore the plugin is installed.

 

I have tried with different credentials and I always get the same error

WP 5.5.1 + Cloudflare + Varnish + Nginx

I have reset all caches and it doesn't work either.

Can someone help me?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +10

@baltasarb 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +12

Hi @baltasarb! Connecting to Wordpress can be tricky because there are lots of different factors that can affect the connection. 

 

It sounds like you’ve looked at a lot of the key factors, but there are a couple of things that we can still look at. Could I trouble you to please take a look at the guide Common Problems with WordPress. If you’re still having trouble connecting your account after looking at that, you’ll need to get in touch with the Support Team using the Get Help form so that they can dig into this with you. 

Good afternoon, thanks for your answers, I have already reviewed "common problems with wordpress" and I think we are not in any of those cases.

I will send a help form where you tell me.

Thank you very much.