Best answer

Error with integrating Wix Automations and Convertkit

  • 8 January 2021
  • 7 replies

Userlevel 1

I’m trying to connect my automation from wix to converkit for an email drip campaign.

I want to send the subscriber from Wix to Convertkit, and add a tag so they are entered in to a specific automation.

When I edit the Zap, it works on Wix’s end. When I test the action on the Converkit side, I keep getting an error.

Does anyone know what I need to do to fix this?


Best answer by nicksimard 9 January 2021, 01:41

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

FYI: A 400 error indicates the request contained incorrect syntax.

In other words, at least one of the field’s inputs was formatted incorrectly.

Can you provide screenshots of how your ConvertKit step is configured in order for us to further evaluate and advise?

Userlevel 1


Userlevel 7
Badge +14

The likely reason for the error is the Email field.

The dynamically mapped data point has a value of “Contact First Email”, which is not a proper email address, hence the error.
In order to test properly, you may have to remove the dynamically mapped data point, input a static/hardcoded dummy email address, TEST, then revert back to the dynamically mapped data point.


Userlevel 1

Thank you!

Userlevel 1

Okay, that worked. However, when I revert back to the dynamic field I get that same error message.


I did discover a different dynamic input that I can use, but I still get that same error message when I go to test.



Userlevel 7
Badge +11

Hi @palatnike!

Based on the screenshot, it looks like those are dummy values and not actually related to a real contact in Wix. I think you might be looking for a field that looks like this, too:

Once you’re 100% sure you’ve chosen the right field, you can skip testing the ConvertKit step since you don’t have a valid email address coming through your mapped field. Then turn the Zap on and test it live to see if everything works as expected :)

Userlevel 1

@nicksimard Thank you so much! It’s working now.