Best answer

Error when I send a Google Drive file as an attachment

Userlevel 1


I have a zap created a long time ago that has always worked. I put some excel files in a Drive folder and I send them by SMTP. The name of this file is the same as the address of the recipient ( With SMTP by ZAPIER (but also with Gmail) I send an email to the recipient's address ( with the file with the same name attached (

. The zap has always worked. Today it doesn't work and it gives me this error: 

“The app returned "Error 400 (Bad Request)!!1".


 After I did some tests I realized that the problem is the attachment. Without attachment it gives no error. What do you think I need to change or check?


Best answer by GetUWired 5 May 2021, 22:56

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +10


I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +12

HI @Vcarnemolla 

I had a similar issue that started yesterday as well. In my case, Google had changed the file preferences for the files in my Drive. Once I updated the file preferences so they were publicly accessible, all went back to normal

Userlevel 1

Thank you!