Dubsado lead created date formatted incorrectly

  • 23 February 2022
  • 1 reply


I'm using Jotform for the various enquiry submission forms we have, and then zapier to trigger the creation of a 'lead project' inside our CRM (Dubsado)… but I'm having a problem with the date formatting.

We're in Australia, and I have a feeling that somewhere along the line it’s getting switched 'US' date format.
I’m trying to discern where along the line this is happening.

When I submit a test enquiry for Dec 10 (that's written 10/12/22 where we are), the Jotform seems to record it correctly (I’ve selected DD/MM/YYYY format on the forms), and the email sent to me has that same date/format.

However, the lead that is created in Dubsado is dated Oct 12 (ie. 12/10/22).
And if it's a date that can't be so easily reformatted, like Feb 23 (entered as 23/2/22) then the lead in Dubsado gets created with no date recorded.

I’ve tried a work around and set the formatting on my Jotform for submission to US style - which technically worked - but this just meant majority of our submitters were unwittingly entering the wrong date ('cause they're all Australians too). And so additional steps to rectify is still required.

I’ve reached out to Dubsado, and they seem to think the issue may lay somewhere in the triggering with Zapier.

ALL ACCOUNTS (Jotform, Zapier & Dubsado) have my timezone as Brisbane/Australia in Account Settings.

Is my problem clear/Does this make sense?
Does anyone have any ideas as to where the miscommunication might be occurring?
Any ideas where to start?

Any help/suggestions would be much appreciated.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +9

Hi @Jake N 

Zapier has a handy formatter to handle date time issues like this. Here is an article on that formatter: 

You can use the formatter to tranform US date into Australian date.