Best answer

Did Quickbooks Invoice custom fields disappear from Zapier?


Userlevel 1

My boss was working on an automation to create Quickbooks invoices after deals from Pipedrive reach a certain stage in their sales life cycle. In Quickbooks Online, there is a custom field that was made to capture an internal note on which project it’s related to, which the client runs reports on.

Previously, this custom field showed up in the list of fields to create in the Quickbooks Create Invoice action, and now it doesn’t appear to be there. There are suspicions that it may be related to the “location” of custom fields in an account’s settings has changed, and/or potentially something that has been paywalled behind Quickbooks Online Advanced. But it’s tough to say.

Has anyone experienced this change as well, and does anyone know how to get these custom fields to return?

icon

Best answer by christina.d 26 October 2021, 19:17

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

24 replies

Userlevel 7
Badge +9

Hi, @NPS_Team! I can see you reached out to the support team, which is perfect. They did respond and had a few follow-up questions for you. 🙂It might be helpful to search by “@zapier.com” in your inbox or check spam if you’re not seeing their replies come through! 

Userlevel 7
Badge +9

Hi there! I’m circling back to anyone following along it appears @NPS_Team may have stumbled on a known bug. I’ve got you added to the list of impacted users and we’ll be sure to send an email and keep this thread updated as soon as we know more.

If you were able to create a workaround in the interim, we’d love to know! 

Hi I am also having this same issue. Added custom field, sent thru an expense with that field, but zapier isn’t showing the custom field on the expense record in question.

 

Can someone let XXXXX@XXXXXXXXXXX.XXX know what the fix is?
 

This post has been edited by a moderator to remove sensitive information. Please remember to not share any personally identifiable information when posting as this is a public forum. 

Userlevel 7
Badge +11

Hey @SideDoor_RM, welcome to the Community! :)

I’ve added you to the list of affected users as well. I don’t have an ETA or workaround to suggest at present but we’ll be in touch via email as soon as the issue has been resolved! 

Userlevel 1

I’m having the same issue. Can you add me to the notification list? Thanks!

Userlevel 7
Badge +9

Thanks for reaching out, @Jay Graves! Of course, I’ve got you added to the list of impacted users. We’ll be sure to let you know as soon as we have an update!

Having the same issue!

What’s the fix for this?

 

Userlevel 7
Badge +9

Thanks for reaching out, @Isaac!

I’ve got you added to that report as an impacted user. While we don’t any updates to provide at the moment, we’ll absolutely send an email notifying users as soon as we do. You can also follow this thread as we’ll be sure to update it once we know more. 

Thank you Christina!

Looks like the issue may be with backward/forward compatibility between version of QBO, namely Plus vs Advanced.  

https://help.developer.intuit.com/s/article/API-response-not-showing-existing-custom-field:

 

Article Body

A custom field will be shown in the API response only if:

  1. It is the first 3 String-based custom field configured in QuickBooks Online Advanced.
  2. It is enabled to all Sales forms(such as Sales Receipt, Invoice, Estimate, Credit Memo, Refund Receipt) or all Purchase forms.        

The mapping of the first three custom fields will be Immutable, i.e. even if the first three fields are marked as 'Inactive' in QuickBooks Advanced, they will still continue to be mapped in the API response.

For details refer to this link:
https://blogs.intuit.com/blog/2019/04/08/enhanced-custom-fields-quickbooks-online-advanced/

To verify this from QBO UI:

  • Login to the QBO Advanced account.
  • Go to Settings (Gear Icon) > LISTS > Custom fields
  • Toggle the button to 'Include inactive'.
  • Now, verify which custom fields satisfies all the above criteria and should be visible in the API response.

 

Those fields that get exposed to the API are only the first three created with type String, even if they get deactivated!

 

Userlevel 7
Badge +11

Thanks for sharing this with us @Isaac! I’ve added these details to the bug report for further investigation :)

Userlevel 1

Hi any update on this? I am also currently being affected by this and it kind of makes zapier useless for me without it being fixed. 

Userlevel 7
Badge +11

Hey @Ddeppner! No further updates I can share at the moment, unfortunately. I’ve added you to the list of affected users.

In the meantime, as Isaac noted above, this could be to do with the version of QuickBooks being used. Are you using Plus or Advanced? 

On QuickBook’s website (here) it states:

A custom field will be shown in the API response only if:

  1. It is the first 3 String-based custom field configured in QuickBooks Online Advanced.
  2. It is enabled to all Sales forms(such as Sales Receipt, Invoice, Estimate, Credit Memo, Refund Receipt) or all Purchase forms.        

The mapping of the first three custom fields will be Immutable, i.e. even if the first three fields are marked as 'Inactive' in QuickBooks Advanced, they will still continue to be mapped in the API response.

For details refer to this link:
https://blogs.intuit.com/blog/2019/04/08/enhanced-custom-fields-quickbooks-online-advanced/

To verify this from QBO UI:

  • Login to the QBO Advanced account.
  • Go to Settings (Gear Icon) > LISTS > Custom fields
  • Toggle the button to 'Include inactive'.
  • Now, verify which custom fields satisfies all the above criteria and should be visible in the API response.

 

So it sounds like if you’re using the Advanced version the first 3 String-based custom fields created (even if marked as inactive) will appear if enabled across all Sales forms.

Userlevel 1

Hi,
I actually already used to Issac’s response to conclude that I am suffering from the same issue. Issac’s response is just an explanation of what’s happening not a fix. Because the 3 custom fields made before are immutable (cannot be changed even if inactive) I can’t work around this because my custom fields are set as transactions and I need them set to Customers (which only QBO advanced allows). If anyone has figured out a work around for this please let me know - I am open to all suggestions even a third party app that integrates directly with QBO. 

 

Badge

I’m also being affected by this - it’s business critical - is there any update??

Please add me to the affected list to track when a fix is available.  We are QBO Advanced. 

Userlevel 6
Badge +3

Hi @CardManc @watergirl.

 

I’ve added you both on the list of impacted users. We will update via email once available. Thanks!

Hello,

 

Please add us to the list of affected users as well. Our Custom Field in Customers is the only one, and doesn’t show when creating a draft. The account matches, but it will not pull the field from QBO into zapier for mapping.

Userlevel 6
Badge +3

Hi @Wildfire Contact

 

I’ve added you to the list of affected users. We’ll update you via email once an update is available. Thanks!

Hey team,

 

I am facing the same issue. Can you please suggest a workaround as it’s business critical.

Userlevel 6
Badge +3

Hi @Birdeye

 

We apologize for the inconvenience. I’ve added you to the list of affected users, and we will update you via email once there is any update.

Hi, We are also facing the same issue while creating the invoice. We have two QB connections. In one connection we are getting our custom filed. But not in another one. Please add us to the list of affected users.  It is really critical for us. 

Userlevel 7
Badge +12

Hi @Cheshta

 

Thanks for your message, I’ve added you as interested user for this feature request. This lets the team know how many people would like to see this addition and we’ll send you an email when we have an update. Thanks!

Hi, please add us to the list of the affected users.

Userlevel 6
Badge +3

Hi @mike_halotherapy 

 

Welcome to the community! I’ve added you to the list of affected users, and we will update you via email once there is any update.