Best answer

Devops connection is throwing "Client secret is expired.".

  • 11 September 2020
  • 57 replies

Userlevel 2



 We been using a zap to connect devops but from last two days we are getting an error. 

  Here is what we are getting when we try to reconnect. The app returned "Client secret is expired.".

I am not sure where we need to update this. 


Best answer by Liz_Roberts 14 October 2020, 14:41

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

57 replies

@Danvers Still no news on this ?

Userlevel 1

While I prefer to see the actual problem solved, I did manage to set up a workaround that does exactly what my old zaps, using the Azure DevOps (AD) connector did.

The connector relies on setting up web hooks in the AD projects. Creating these hooks manually is however easily done under the AD project settings in the console (Project settings → General → service hooks)

Simply create a zap starting from a Zapier web hook that accepts a POST request. Use the Zapier hook URL to configure one or more web hooks in an AD project, and then complete the zap with the remaining logic from the faulty zap.

@Danvers and all others following this thread, Microsoft just released a fix as indicated in this :

On my side, it’s now now finally fully functional (after a month down...)

Userlevel 7
Badge +12

Hi everyone! We’ve received the following message from the team working to resolve this with Azure Dev Ops. The short version is that, as @lumed  said, it should be working now. 

Here’s the message from our team:

We've worked with the Azure Dev Ops team to identify the issues with connecting / maintaining a connection from Azure DevOps to Zapier. They've recently written in to let us know that they have taken steps to resolve these errors.

I hope you can give this another try soon. If you do happen to encounter this issue again (or any other issue!), please let our team know so we can work to resolve it.

Userlevel 1

I can confirm this is working again.  Thanks!!

Hi I tried to log in again with Azure DevOps account and I get the following error. 


Userlevel 7
Badge +8

Hi All,

It appears that this issue has been fixed! If you are still encountering any issues, you may need to contact our Support team so that they can assist!