Best answer

Couldn't retrive email field in MindMint - MailChimp Zap

  • 15 April 2020
  • 5 replies

Hello everybody, as described in the title i’m having an issue related to the parse of the email field;
The zap is configured to: When sync Attendees ( Having a new attendee in a event) add a new subscriber in Mailchimp. So the problem comes after the configuration of the zap (which runs smothly, without any error, even creates the new subscriber with the data provided) when i test with a new attendee created in MindMint; it didn’t creates a new subscriber, and when i check the task history there’s always the same problem: the email field couldn’t retrieve the data; I checked many post here on the forum and it didn’t seem to be my problem (The most common problem is that people tends to write the email directly in the field, and do not use the correct mapping, i tried many times to remake this step, but always with the same result). So i’m stucked here without knowing what to do with the zap ( i remake the zap willing to solve the problem but the same result) so i really could use some advices. 

Thank you!

PS: sorry for my bad english.


Best answer by steph.n 2 June 2020, 08:30

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +11

Hi there!

What sometimes happens with Zaps is that when you test the trigger, the fields that are shown to contain the data that you need are slightly different when the Zap actually runs live. It sounds like your Zap has run at least once. Now that it has, can you try re-testing the trigger to pull in a new sample,  to see if the fields that you currently have mapped on the MailChimp step end up showing No Data

If that’s the case, then re-map the fields to use the ones that got pulled in with your most recent test.

NOTE: After you click on Load More, make sure to select the new sample and not keep the old one selected.

Can you give that a try to see if it helps?

Hello, once again. Thanks for your answer!

I tried what you suggest me, but in the end there was no change at all. I change the sample and the error was still there, it only happends when i add a new attendee, and when i test the zap i didn’t trigger any error.

Here’s the log of what show the data input in the task history.


2. This Mailchimp step hit an error.












{{84131217__phone}} Required field "Subscriber Email" (email) is missing. This step is missing a required value. Usually this is because that field was empty because a previous step didn’t provide the data it needed.


Userlevel 7
Badge +11

Hi @Occlusion Craftman

It seems that we'll need to investigate this further, so I'm escalating this to our Support team. They can provide you with the attention you need to resolve this issue in a timely fashion.

Sorry to bounce you around, but they really will be best equipped to help you out with this one, as it will likely involve some deeper troubleshooting :)

Userlevel 7
Badge +8

Hi @Occlusion Craftman - Thanks for being patient. It looks like Cameron from Zapier Support responded to you and we think it’s a great answer to share with the community:

So sorry about this! I've investigated into the issue further, and it looks like you're being affected by an issue where MindMint returns the sample data differently to how it is actually returned when your Zap is triggered live. Because of this mismatch in their app, you cannot map the fields correctly.

To give you some context, the MindMint app is developed and maintained by the people who make that product. I’ve done some more digging and it looks like they need to fix the issue that is occurring on their end. However, we track issues like this in a system that lets the developers know when we receive bug reports from folks like you. It also lets us email you when any changes or updates occur. Other users have also reported this issue, so I’ve gone ahead and added your email address to the existing report for it. While I can’t say for certain when this will get resolved, I can promise that we’ll let you know when it’s rolled out!

Additionally, we highly recommend that you reach out to MindMint and request that they implement this fix. Our partners generally respond more quickly when they hear from their own customers and it’ll raise the visibility of your needs.


That said, I've gone ahead and submitted this as a feature request to the team in charge of this integration on your behalf.

While not all feature requests are implemented, customer feedback like this is a huge part of how we continue to grow our platform. If this feature does get developed, we'll reach out to you directly to let you know!

We are running into the exact same issues with Mailchimp in Zapier, and it doesn't matter from which app the info is coming from. 

  • We have tried Agile CRM to MailChimp - test runs fine, in live it always fails
  • We have tried Demio to Mailchimp - test runs fine, in live it always fails
  • We have a multi step Zap: Agile CRM to to Slack to Mailchimp. All steps work flawlessly except for the Mailchimp step. Always the same message ‘Required field "Subscriber Email" (email) is missing.’. 

Can this be a bug in the Mailchimp Zap?