Best answer

Can’t turn on Zoho CRM Zap due to “Permission Denied” error

  • 1 February 2021
  • 3 replies
  • 638 views

Hello everyone, 

I created a zap in order to link incoming leads from the Linkedin Lead Gean form campaign, and the Zoho CRM of my company.
For 2 weeks, the connection has been made with Linkedin, but does not work with Zoho.
I tried several to reconnect to it, and the same error message appears "This account is expired.Please reconnect it here.". But, this account is work already, and in the Zoho CRM there is no problem. I try it with 2 differents accounts. 

Indeed, the connection is successful, but a few seconds after that disconnects again and I cannot continue the zap configuration.
I have logged out of Linkedin, Zoho crm several times and have to start all over again but the same problem keeps coming back.
Has anyone already encountered this type of problem? Or has a solution for this?

You will find 2 screenshot bellow to explain more my problem. 
Thank you so much,
Have a good day


 

icon

Best answer by SamB 7 July 2021, 12:18

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +14

Hi @Frédéric 

Check out these help suggestions: https://zapier.com/help/doc/common-problems-zoho-crm

Userlevel 7
Badge +10

@Frédéric 
Just checking in to see if you still need help with this? 

Userlevel 7
Badge +11

Just wanted to follow up here as it seems that @Frédéric reached out to our Support team who were able to identify the cause of the error. Sharing their response here for others running into that same error:
 

I checked the logs for this Zap and see that we're getting this error message from Zoho:

{ "code": "NO_PERMISSION", "details": { "permissions": ["Crm_Implied_Api_Access"] }, "message": "permission denied", "status": "error" }

The above exception will be thrown when your account doesn't have permission for API access.

You can enable permission for this under Settings --> Security Control --> Profile --> User's profile --> Enable the option "Zoho CRM API Access".