Question

Can't complete Docusign zap - "We’re having trouble loading 'Template ID' data" error


Badge

 

Creating a simple Zap to catch a simple “Signature Request”. This is with a new account so I should have the 14 days paid professional access. Several of the dropdowns aren’t populated and gives me “We’re having trouble loading 'Template ID' data (Cannot read property 'map' of undefined)”.

 

I can’t set the recipient role either:

Any clues?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

19 replies

Userlevel 7
Badge +14

Hi @davehodg 

Check your DocuSign connection here: https://zapier.com/app/connections

 

Zap with Envelope sent or completed trigger not triggering/can't pull samples

A paid plan is needed to use this trigger.

 

Any other potential restrictions with the DocuSign integration?

The envelope sent or completed trigger only checks for new envelopes every 15 minutes.

Badge

I can’t enable the Zap. There’s a (!) mark on stage 2 complaining about the fields, but as I said, “Template ID” and “Recipient Role” throw errors as in the screen grabs above.

Userlevel 7
Badge +14

@davehodg 

Do you have a DocuSign paid plan as indicated here?

Zap with Envelope sent or completed trigger not triggering/can't pull samples

A paid plan is needed to use this trigger.

 

Did you check your DocuSign connection here?

https://zapier.com/app/connections

Badge

As said above, I’m in my first two weeks. That’s counts as paid, no?

Yes, “testing the connection” works, just those two fields don’t work as in the dropdown.

 

Userlevel 7
Badge +14

@davehodg

A Zapier paid plan is different than a DocuSign paid plan.

For some apps you need both.

Also, a Zapier trial version is not necessarily a paid plan.

Badge

So do I need a Docusign paid account?

Userlevel 7
Badge +14

@davehodg 

Appears so.

Info is taken from this DocuSign Zap app integration help article: https://zapier.com/help/doc/common-problems-with-docusign-on-zapier

You can open a ticket with Zapier Support to further clarify: https://zapier.com/app/get-help

Badge

That page doesn’t say if it’s a Zapier or Docusign account that’s needed.

Badge

I have 12 days left of my Zapier free trial and 28 days left of the Docusign.

Userlevel 7
Badge +10

Hey @davehodg,

It is possible to use the DocuSign integration while on a free trial of Zapier. That said, I did some digging on this end and it seems that you definitely need to be on a paid DocuSign plan. Free or trial DocuSign accounts won’t work with the DocuSign integration, unfortunately.

Sorry to not have better news here but I hope this helps to clarify! :)

Badge

I’m happy to cough up for Docusign, if that’s what it takes.

It’s odd though, I can set up a webhook and a docusign step, but it tells me it’s not complete, but I’ve filled everyhing in and it doesn’t tell me what’s missing!

Userlevel 7
Badge +14

@davehodg 

Best to provide screenshots to illustrate how your Zap steps are configured and the errors.

Userlevel 7
Badge +10

Hey @davehodg,

It could be that the other “not complete” error is also related to the DocuSign account not being on a paid plan. But if you upgrade to a DocuSign paid account and are still seeing a “not complete” error, then it might also be a validation issue of some kind. Where there’s a field that’s receiving a value that DocuSign isn’t expecting, as I’ve seen similar behaviour with other apps in the past.

I’d recommend reaching out to our Support team to investigate these errors further. They’ll be able to dig into the detailed logs for your Zaps and be better able to troubleshoot this with you. The best way to reach them is through the Get Help form. Please do report back here to let us know if you’re able to get to the bottom of it with them! :)

Badge

As soon as I’ve paid for DocuSign I’ll prepare with screen shots. I’m now not seeing the errors that kicked this post off!

Userlevel 7
Badge +10

I’m so glad to hear you’re no long seeing those errors, @davehodg

Did you happen to make any changes to the Zap or your DocuSign account right before the errors stopped appearing? Would love to know if there was a specific change made that fixed the errors. :)

Badge

OK, I’m back to where I was. I’ve create a raw webhook (is 2MB going to be enough for us?), start creating the Docusign one and I get:

 

Same for “Recipient Role”. I now have a paid DocuSign account for whatever that’s worth. I’m still on the free 14 days with Zapier.

Could someone else please try setting this up?

Userlevel 7
Badge +10

Oh no, @davehodg! I’m so sorry to hear the error is back! :(

I’m not too sure whether 2MB will be enough, it would really depend on the size of what needs to be sent. I think the best thing for you to do here will be to reach out to our Support team. They will be better able to investigate those errors further and help you get this solved! 

Badge

I’ve emailed the support team.

I’d like to hear from anyone who has successfully done this!

 

Userlevel 7
Badge +10

That’s great to hear, @davehodg! :)

If you’re able to get this solved, please do let us know!