Question

BIG ISSUE: Wordpress (Legacy)

  • 27 January 2022
  • 1 reply
  • 63 views

Hello, I have a zap that has been used more than 1000+ times, it has not been touched since last year November. It suddenly stopped triggering today. I did not update any plugin. I tested with a new zap in the same wordpress account and when I test the trigger, it does not find the new post.

Trigger Event: New Post

Post Status: Private

Post Type: MyCustomPostTypeName

That’s about it for the settings. And it is not finding new posts. It just says “We couldn't find any more new posts.
Create a new new post in your account and try again.”

 

This is clearly an issue on Zapier’s side because this has never happened before. It just started happening now. I really need a fix on this.

 

UPDATE: I tried creating a new zap but using the new Wordpress App and NOT the legacy one. It worked, it successfully found the new posts. But the problem with the new Wordpress app is that it does not detect custom fields which vital to my operation. 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 3
Badge +1

I use custom fields as well, and the solution that works reliably for me is to have Wordpress send a copy of the order email to Zapier, which parses the order number from the subject line, then uses the Wordpress API to fetch the entire order object - which includes absolutely everything about the order. That can be parsed and used however you wish.

I use this approach with several of my Wordpress sites, and it works like a charm. If you need further information, please send me a private message.

Joey