Best answer

Asana task ID + GSheets

  • 1 June 2020
  • 6 replies
  • 352 views

Userlevel 2
Badge +1

Hey my Zap Happy Community!

I’ve got a Zap for my hiring process that when a candidate submits their resume it gets added to an Asana project as a task. The task ID gets added to a GSheet with some other info to be used later.

As they progress through our hiring process, I use a find row action for GSheet with their email address to find the Asana task ID. For whatever reason, Zapier can’t recognize the task ID when I try to find it in Asana. I set up an additional step to remind myself to go put an apostrophe in front of the task ID in GSheet so it shows the whole number on the GSheet (instead of for example 1.1781E+15). That didn’t work. 

I’m wondering if anyone knows how to make Zapier recognize the Asana ID to be used in the find task by ID action step? 

Appreciate your help.

Cheers!

icon

Best answer by blueprintbrian 4 June 2020, 15:14

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +8

Hi @blueprintbrian ,

Thanks for reaching out to us! Could you please share a screenshot of your configuration so that we can take a look at your Zap’s mapping? 

Will be on the lookout for your response and we can dig in from there!

Userlevel 2
Badge +1

Hi @Liz_Roberts. Thanks for responding.

I did end up changing the action step to “find task in a project”. That seems to work. I guess my worry is that maybe a task could be named the same in the future. Very small chance that would happen. Using the task ID would mean it’s a completely different task ID on each task, so would remove this worry. 

This screenshot is from zap 1 that adds the info to the Excel worksheet:

 

Then the candidate responds back with a specific subject in the next step of the hiring process. This screenshot shows the “find task in project” in Asana action. The Asana Card ID doesn’t get pulled in correctly. Here, it would show as 1.1781E+15 instead of what shows currently. Even if I change it to text or general in the Excel sheet and add an apostrophe before the number, Zapier won’t pick up that it matches to the Asana card ID:

 

So, for now I’ve created another column that pulls in the persons name and the role they’re applying for as the name of the asana card on a project board. That’s the Task Name in the above screenshot. Seems to work but obviously the card ID would be better to use.

Cheers!

Userlevel 7
Badge +12

Hi @blueprintbrian

 

I’ve done something similar with Google sheets rather than Excel and even if the sheet shows a number as something like ‘1.1781E+15’ the Zap should still pull the whole number from the sheet. Is that what you saw when you were mapping the fields from the sheet? Or did you see the number as ‘1.1781E+15’ in the Zap?

 

Could you try the Asana step again and this time manually type in the task number to see if that works? That will tell us if it’s a problem finding the task from the number, or if the issue is the way that the number is coming from Excel. Also, could you confirm which Asana action you were using before you switched to the ‘Find a Task in Project’ search action? Thanks!

Userlevel 2
Badge +1

I typed in the task ID but it didn’t find it. I see what happened. I went and found the task ID in the zap I was working on as 1178098328040009, but when I went to Excel it dropped the 9 and converted it to a 0 on the end. Thus making it wrong. And when I change it in the Excel, it converts it back to a 0 instead of the 9. Strange. Thoughts on that? I might need to switch to GSheets for this.

 

I’m not surprised that GSheets works better than Excel. I considered doing this there because I use it for other reasons, but I wanted to have everything in my OneDrive so things aren’t spread across OD and GD.

Userlevel 7
Badge +10

@blueprintbrian - have you tried setting the format of that column in Excel to ‘Plain Text’? It’s most likely set to ‘Auto’ which is why you’ll be seeing those issues.

Userlevel 2
Badge +1

@AndrewJDavison_Luhhu it was set to General, but I changed it to Text and it still didn’t work. I’ve switched this over to using GSheets and it seems to be working now so I guess I’ll stick with what works. Thanks for the feedback.