Best answer

Asana + Buffer, attachement issues

  • 12 April 2021
  • 2 replies
  • 175 views

Hello,

I am trying to setup a Zapier interface for Asana and Buffer.
Everything works, except the most important part : the attachement.

It returns an error “The provided image does not appear to be valid.”
I figure this is because the like is signed by amazon AWS and cannot be use indefinitely.

I tried Formatter to modify the url before fetching it, still no luck.
How can we allow buffer to retrieve attachement from Asana then ?

Here is my zap if that can help : Zapier | The easiest way to automate your work | Zapier

The error :

 

 

 

Thank you for your support

icon

Best answer by flupke70 12 April 2021, 18:32

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +14

Hi @flupke70 

Make sure the file URL is publicly accessible.

You can test this by copy/pasting the file URL being used in a private browser.

If it renders/displays, then the file is publicly accessible and should be able to be used in the Zap.

That’s the thing, i think asana hides the upload behind an URL that is created on check with token every time.. So i figure this is going to be difficult to resolve on my end..

For the time being i switched to Trello and thinks works smooth there for this exact purpose.

 

Thank you