Best answer

Applying a Date / Time Formatter to Line Items > not skipping null items

  • 20 February 2023
  • 7 replies

Userlevel 1

I am using Zapier to send a Gravity Forms trigger to Airtable. The Gravity Forms form is used to receive up to 9 meeting dates + meeting topics. Each of these meetings should become an individual record in Airtable. 

The form has the following fields that are read as line items:

Start time
End time

This list repeats 9 times in the Gravity Forms form.

Users can decide how many meetings they want to register, i.e. they can fill in 3 dates, or 9, or 1, etc. 

Second step

The second step in Zapier (after pulling in the data) is a Line Itemizer. This works like a charm. 

Third step

The third step is combining the date and start time and converting this to the format Airtable can read. This data is later used to create new records with a Date and Time field in Airtable. 

Resulting in:


Problem statement: 

Now all of a sudden the date input reads “now”, instead of the blank or null it was in the second step. 

According to this help article, this is a common problem: 

But, why can’t Zapier parse the ‘no data’ dates as blanks


Best answer by Danvers 22 February 2023, 10:46

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 1

Update (not solved):

I have also tried this approach I found, to apply a spreadsheet-style formula to make sure the empty fields are read as blanks. 

It seems absolutely mute, mostly because it is mute. The results:

 Or even these results:

All give the same output, in which the date is set as “now” and time at 0000.


Userlevel 7
Badge +14


Good question.

You can try instead to use the Looping app:

Then follow that with a Filter step:

This way only line items that exist with data values are processed.




The issue is because of this Formatter step, which is considering a blank/empty/null value as now and transforming that into the desired format.


Userlevel 7
Badge +12

Hi @JortArie!

It looks like you’ve found all the right information and tried the right things, but Formatter isn’t playing ball, I’m sorry about that. 

I wonder if this is happening because the blank value is within a line-item, so for some reason the Formatter isn’t reading it as blank. You could test that theory by trying out a blank value that’s not a line item (ie you could try the Formatter step and not map anything in the field. That would get you the answer as to what the issue is but of course it wouldn’t fix it. 

One approach is what Troy suggested and using Looping and a filter step so the Formatter step only happens where there is a date to convert. This might not work for you, depending on what steps you need after the Formatter step. Could you let us know if it could work for you?



Userlevel 7
Badge +12

Hi @JortArie!

This one was puzzling me so I did some more digging and I think I’ve found the solution. 

If you remove the hard-coded (typed-in) comma between the two input values and replace it with a space, that should do the trick. 


The hard coded , in the input is making the Date/Time Formatter action think there’s data after those null values in the YYYY-MM-DD data, so Formatter interprets them as “now” when it runs or is tested. The line items need to be ‘clean’ for the Formatter to iterate over them. 


Give that a go, and let us know how you get on!



Userlevel 1

If you remove the hard-coded (typed-in) comma between the two input values and replace it with a space, that should do the trick. 

@Danvers and @Troy Tessalone, thanks so much for your time and input! 

@Danvers you are amazing! This has indeed fully solved the issue. The formatter is now outputting as intended:


There seems to always be a single misplaced comma, haha! Glad this was it though. Really, really appreciate all of your help. Legends!

Userlevel 7
Badge +12

Fantastic! So glad this did the trick 😃

Userlevel 1

Another update for whoever might find this thread in the future - this might also solve some issues: