Best answer

Why won't "usd" be accepted as a valid Currency type?


Userlevel 1

I’m attempting to create a new Zap which creates a new Deal in ActiveCampaign when an order has been placed on an ecommerce site hosted by BigCommerce. However, I can’t get past the test stage and keep getting error 422. The full error message states the following:

“The app returned "Invalid currency provided. The length must be 3. e.g. usd, gbp, aud or cny.". This can occur if the information entered into a field is not in the correct format. Double-check that you are using the correct format for entering values into a field. We made a request to zapier.app-us1.com and received (422) Nginx/1.16.1.”

The values I has tested are “USD” and “usd”, but both are rejected as invalid. Any ideas?

icon

Best answer by TopDog 19 June 2020, 22:43

@nicksimard Someone else eventually got back to me that the field is looking for a specific format like “USD 123.00” and not just “USD”. What would have helped is if somewhere in the UI or an easy to find help doc would have stated that but it wasn’t and caused me a lot of trouble for a long time.

This matter can be closed.

View original

This topic has been closed for comments

10 replies

Userlevel 7
Badge +10

Hi @TopDog 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 3

I’m attempting to create a new Zap which creates a new Deal in ActiveCampaign when an order has been placed on an ecommerce site hosted by BigCommerce. However, I can’t get past the test stage and keep getting error 422. The full error message states the following:

“The app returned "Invalid currency provided. The length must be 3. e.g. usd, gbp, aud or cny.". This can occur if the information entered into a field is not in the correct format. Double-check that you are using the correct format for entering values into a field. We made a request to zapier.app-us1.com and received (422) Nginx/1.16.1.”

The values I has tested are “USD” and “usd”, but both are rejected as invalid. Any ideas?

 

Just a question, purely based on how many times I’ve hit this particular wall - is there perhaps a random space either before or after the ‘usd’ in the field that you are testing 

Sometimes that additional space can create the error - may not be true in your circumstance though.

Userlevel 1

I’m attempting to create a new Zap which creates a new Deal in ActiveCampaign when an order has been placed on an ecommerce site hosted by BigCommerce. However, I can’t get past the test stage and keep getting error 422. The full error message states the following:

“The app returned "Invalid currency provided. The length must be 3. e.g. usd, gbp, aud or cny.". This can occur if the information entered into a field is not in the correct format. Double-check that you are using the correct format for entering values into a field. We made a request to zapier.app-us1.com and received (422) Nginx/1.16.1.”

The values I has tested are “USD” and “usd”, but both are rejected as invalid. Any ideas?

 

Just a question, purely based on how many times I’ve hit this particular wall - is there perhaps a random space either before or after the ‘usd’ in the field that you are testing 

Sometimes that additional space can create the error - may not be true in your circumstance though.

No, I specifically checked for that and no space. It is really odd.

Userlevel 1

Hi @TopDog 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

I can perform a screen share session or upload screenshots if that would help.

Thanks @AndrewJDavison_Luhhu !

@TopDog thanks for reaching out- sorry you’re running into this error!

I'm thinking that the error that's showing is sort of a false flag. There are a few fields that require a specific format that may need tweaking. I'm wondering if fixing these issues will fix the error that keeps presenting itself.

Within the ActiveCampaign step, under “Customize Deal,” could you take a look at the fields that have a notation “Format: CurrencyCode [-]#####.## Eg: "USD 77.50", "JPY -55000.00", "EUR 8.99"” below them? This notation will look like the below:

 

Try double-checking the formatting of these fields and let us know if that does the trick! If not, we’ll dig deeper!

Userlevel 1

This is what I have that is throwing the error. I also tried deleting the dynamic data from BigCommerce and just typed, “USD” and “usd”but to no avail. Any ideas?

 

 

Userlevel 7
Badge +11

Hi @TopDog I’m sorry that we weren’t able to help you with this one in the community. Are you still having trouble with this? If so please let me know and we can escalate this to the Support Team. Thank you!

Userlevel 7
Badge +10

Hi @TopDog!

Since this was a little while ago, I wanted to check in to see if you’d managed to solve this or whether you still needed help here. Please let us know!

Userlevel 1

@nicksimard Someone else eventually got back to me that the field is looking for a specific format like “USD 123.00” and not just “USD”. What would have helped is if somewhere in the UI or an easy to find help doc would have stated that but it wasn’t and caused me a lot of trouble for a long time.

This matter can be closed.

Userlevel 7
Badge +7

@TopDog ,

Thank you for letting us know you were able to resolve this issue. I am passing along your feedback to our UX team regarding documentation- please let us know if you have any additional questions on this topic or anything else. Happy to help!