Question

Webflow form to HubSpot contact Zap keeps breaking

  • 13 September 2021
  • 3 replies
  • 19 views

I have a Zap set up so when a user fills in a form on our website (webflow), it triggers a flow that creates a contact in Hubspot and fills in the contact with the basic data gathered from the form; First Name, Last Name, Email, Phone No., Years Experience and Profession. 

Most of the data is pulls into the Hubspot contact when it is created, all apart from First Name and Last name. 

There are no issues with Years experience, Profession, Email when Zapier gets hubspot to create the contact. 

 

I have fixed this issue multiple times now and every time it just randomly stops pulling those two form fields.

 

Please help before I throw my laptop out a 9th floor window!


3 replies

Userlevel 2
Badge

Hi @SonnyWellness 

Are you able to provide any additional information on steps to map the fields from the form submission to then being passed into HubSpot?

 

For example are both naming fields coming through as separate fields in the form submission or are you using a formatting step to split the string and then map to HubSpot fields?

 

The basic structure would be:

Trigger: Webflow form submission

Action: Search or Create HubSpot Contact

 

HubSpot also uses email as a Unique Identifier, so you would likely need a Search / Find Contact step for HubSpot to see if a contact already exists, and if not, create.

 

If you can provide any additional details on action steps taken between Trigger and passing this into HubSpot that would be great.

Regards, Michael 

Hi Michael,

 

Thanks for replying to my issue!

First name and Last name are separate fields in our form, and on Hubspot. For example, in the action “create a contact” Zapier takes the data like this:

 

Below is what I currently have set up as a zap.

 

 

So are you saying I need a step prior to contact being made to check if there already is a contact?

Again, thanks for your assistance!

Userlevel 2
Badge

Hi @SonnyWellness 

Thanks for the additional information.

 

It would be helpful to have a 'search' step in HubSpot to see if a contact already exists before creating. However this likely won't be your issue with the data coming from the form.

 

If you are able to show a screenshot of the Trigger test data step to show how the First and Last name data come through the trigger that would be great.

Generally the only reason this would break after previously working, is if any finds have been updated in your form which may cause previous mapping to break, but if you can show the additional trigger data I can have a closer look.

 

Regards, Michael

Reply