Best answer

I'm unable to publish my Zap draft


Userlevel 2

I am trying to update and re-publish an existing zap. I can't seem to get rid of the (has draft) notification on my Zap list. When I have been able to get to the place where the 'Publish' button is activated (it looks greyed out even when activated BTW) it says it will publish, then turn on the Zap ... but it doesn't. It says the modified Zap is published successfully but the (has draft) is still there, and the zap isn't turned on. What gives?

icon

Best answer by christina.d 29 April 2022, 19:01

View original

46 replies

Userlevel 7
Badge +13

Hi @MikeTak 

Good question.

Can you post screenshots of what you are seeing so we have more context?

I’m also seeing this issue. Zap has been edited and tested, but there is no ability to publish it.

 

 

Same issue here, can’t publish. Never had this problem before. Have you found a solution?

Hello, 

I have the same issue and cant publish a draft - the Zap has worded for ages but suddenly stoped working - so thought I would update this but now its changed and it wants me to publish the draft but its greyed out? 

Userlevel 7
Badge +8

Hey @MikeTak thanks for surfacing this! I am not sure why this is happening for you so I would recommend reaching out to our support team so they can dig in further: https://zapier.com/app/get-help

Keep us posted with the outcome! We’d love to inform others that may be experiencing this issue as well!

Userlevel 1

I’m also having this issue. The Publish button is always greyed out and my edits aren’t being saved

Userlevel 1

A work-around that works for me is to duplicate the zap. You can then make edits in the duplicated zap and it lets you publish them.

Same issue here. I just edited a zap and the publish button is grayed out. 

Userlevel 1

I am also have the exact same issue as OP

Userlevel 1

Hey @MikeTak thanks for surfacing this! I am not sure why this is happening for you so I would recommend reaching out to our support team so they can dig in further: https://zapier.com/app/get-help

Keep us posted with the outcome! We’d love to inform others that may be experiencing this issue as well!

 

This seems to be a wider community issues, rather than each of us contacting support individually, could you let us know if :

A work-around that works for me is to duplicate the zap. You can then make edits in the duplicated zap and it lets you publish them.

 

^^  ...this is the best solution?

 

Are we really expected to have multiple versions of the same Zap, each with its own little update?

 

Can you please let us know how to re publish existing Zaps, that have been edited/updated. 

Userlevel 1

I dont know if they fixed something, but now there is a “Ready to Publish” suggestion at the bottom of the active zappier window. 

 

Happy Zapping :)

I dont know if they fixed something, but now there is a “Ready to Publish” suggestion at the bottom of the active zappier window. 

 

Happy Zapping :)

 

Unfortunately not with my Zaps :/

Any updates on this? Having the same issue - the first three had the publish option but the last one doesn’t!?

Userlevel 7
Badge +8

Hi there, friends. Thanks so much for reaching out! We definitely appreciate the feedback and ya’ll reporting this. 

Hey @MikeTak thanks for surfacing this! I am not sure why this is happening for you so I would recommend reaching out to our support team so they can dig in further: https://zapier.com/app/get-help

Keep us posted with the outcome! We’d love to inform others that may be experiencing this issue as well!

The reason we recommend filing tickets with support in this case is because it can be tricky to triage new issues in the Community without knowing the full scope. While we’re always happy to add users to existing bugs, surfacing new ones can be difficult and is best left to the experts in support who have the ability to check each individuals specific settings, logs, and isolate issues to a more granular level we simply do not have in Community.

Thanks in advance for your help in getting this sorted! In the meantime, here is a workaround that has been helpful for some folks:

  

This worked for me (for zaps that were already published/live, but that couldn’t publish new edits/drafts)

So, while you’re in the problematic zap (while you’re editing the draft and the “publish” button is grey and unresponsive): 

  1. First click “Save draft & Exit” button; 
  2. Then disable the zap (turn it off right there); 
  3. The re-enable the zap (turn it back on); 
  4. A popup should appear with options to publish your draft - select that option where you publish and enable your draft. 

This’s just saved the day for me! 

Jelena

 

Userlevel 2

I will set up a ticket if the behaviour persists … NOTE - I agree that the behaviour the prompted the original complaint has changed since I first posted. Things are working better now.

Same thing here, duplicated a ZAP made some changes. Can not publish changes, the button is greyed out I did submit a ticket, this is crazy. Never had any issues, fix this.

Same, I duplicated the draft and cannot still publish. It only gives option to save and exit draft. 

Userlevel 1

I am having exactly the same problem. This began as soon as the new feature of ‘edit draft’ -- while the zap was still live -- came about for me so I think Zapier introduced a bug. It will not allow me to publish my zap despite that my edit was totally trivial (to a content field, not any of the process steps of the zap itself).

I’ve done some testing on this:

1/ Duplicate zap. Will not allow saving.

2/ Turn off (duplicate) zap prior to clicking edit. Will not allow saving.

3/ Delete ‘draft’ entirely. Start over: click edit. Will not allow saving.

Basically Zapier is somewhat broken right now: you cannot save edits to any zap. I will go file a formal ticket but this is just clogging up your customer service queue, it’s clear this is something QA and tech should be looking at ASAP given the number of complaints in such a short time -- and that it seems fully broken in this respect and being able to edit/change is a critical function.

Edit: I followed the staff link posted above to create a ticket. It made me login yet again (since I had to again for this help forum, that’s the third time), then when I did successfully, returned me to the same page that asked me to login yet again. I scrolled through the page and none of the options were creating a ticket. Whether this is because it’s not registering the login, or because it’s just trying to divert me into reading FAQs and so on, I’m not sure. So, in the end, I did not create a ticket.

I am having the same issues as indicated above.  I cannot run the zap and there is no way to get it to publish.

Userlevel 7
Badge +11

Hi @donnab, @PJ.Gaenir, @vanessa and @DwayneRoberts! Thanks for hopping into the thread and I’m sorry that you’re having problems with draft Zaps.

 

As @christina.d mentioned, the best thing to do here is to get in touch with the Support Team using the Get Help Form. The Support Team can dig into your Zaps and all of the back end logs with you to better understand what might be happening in your case. Thanks!

same, this is ridiculous.

Same issue.

Same issue. I created a ticket and find that support isn’t even available weekends. I’m running a business that doesn’t wait until Monday.

Ah… So it’s not just me! I can manually trigger each step, but obviously this is not ideal! I have logged a support request. Hope the devs can resolve this soon.

Just want to add to this thread to encourage Zapier to take action - I have the same issue with being unable to publish edited zaps and being stuck with unpublished drafts. @Zapier, please fix this asap, it’s an f*ing nightmare to work with your tool like this...

Reply