Best answer

Zap triggers multiple times from single webhook that’s received

  • 5 February 2021
  • 10 replies
  • 861 views

Hi,

I have a zap that sends out a welcome email to the subscriber once they registered.  However, lately I noticed that 6 of the same emails are being sent.  Is this a bug?  I double checked my zap and confirmed only 1 email should be sent out.

 

Do you have any similar experience and found a fix on this? thank you.

icon

Best answer by rwu 25 February 2021, 19:29

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

10 replies

Userlevel 7
Badge +14

Hi @rwu 

Can you clarify what apps are being used in your Zap?

Can you clarify what the trigger event is for the trigger app in the Zap?

Check your Zap Runs to see if the timestamp is the same for each triggered Zap: https://zapier.com/app/history/

Yes, 

 

time stamps are the same for all 6 emails.

 

apps used on this zap are:

 

  1. jotform (where people out the form and make a payment)
  2. google sheet ( to log this user on the sheet)
  3. gmail (send email to the user to welcome them).

The 3rd step fires 6 times. step 1 and 2 all firing correctly.

 

Thanks Troy.

 

 

Userlevel 7
Badge +14

@rwu 

You may want to open a ticket with Zapier Support to have them investigate: https://zapier.com/app/get-help

I did.  I used “something else” category and submitted my issue over 10 days ago no response yet.  Also there is no confirmation or ticket number being generated using that method of submission. 
 

thanks.

Userlevel 7
Badge +14

@rwu 

Check your spam/junk folder of your email account.

Perhaps try submitting another ticket using a different category.

Userlevel 7
Badge +10

@rwu 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +12

Hi @rwu! I can see that you submitted a ticket to our support team a couple of weeks ago and again yesterday, it must be frustrating to not have seen a response. 

 

I can see that your first ticket has been responded to. If you can’t see it in your inbox, please could you check your Spam folder? If you have a Gmail inbox it may have gone to your Promotions folders as some of our emails get redirected there. If you still can’t see it, try searching your emails for ‘zapier.com’ and that should surface it. 

 

We do have an autoresponder, which lets you know that we’ve received your ticket, so if you don’t see that, that’s a good sign that for some reason our emails aren’t reaching your main inbox. 

 

I hope that helps!

 

 

Userlevel 7
Badge +12

@rwu 

I would look over what data is being returned when the events fire multiple times. Is it all the same? From my experience with form triggers, it is sometimes necessary to implement a filter step immediately after the form. Especially when payments are involved. If your forms have a save for later option or anything similar it may trigger multiple times but with different statuses (I.e. submitted, Reviewed, paid, etc). 

Look over the data returned in the triggered events carefully under your Zap history and see if there is a way to filter. 

Thank you. i resubmitted the ticket again and hopefully they reply. much appreciated.

Zappier support got back to me.  It turns out my webhook returns an array therefore whatever comes after it firing multiple times based on the array.  I cannot change that since it’s from my app so I found a temporary fix, which is to move everything after the webhook to before the webhook, that at least corrected this problem.  I’m still trying to talk to my app dev team to see if there’s anything can be done to the way the webhook URL is setup and will report here if i get any update.  Otherwsise, this issue is closed as i found a temporary fix to this. Thank you everyone.