Question

POST as Form in Webhook always sends as JSON?

  • 28 September 2022
  • 5 replies
  • 27 views

Userlevel 1

I am trying to get Zapier’s POST Webhook to work, but without any success.

First, Zapier does an extremely poor job showing what actually gets send to a webhook. I had to use Postman to analyze the body that Zapier is submitting out.

What turns out, when you select POST and FORM in Zapier, what being sent is always JSON!! Below is what Postman receives from Zapier:

With these settings:

 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +12

@Picto 

Sorry for your trouble with this! It appears it is dictated in the action that to send form encoded values you must use the Custom Request feature. I will agree that if that’s the case you would think the form payload type wouldn’t be an option! 

Were you successful in sending data just as a long URL with dynamic params? 

i.e {{base_url}}?api_key={{key}}&image={{image}}

 

Userlevel 1

Yes, I was able to get it working, but now the next challenge appears. The response is JSON, but it’s being returned as plain text (all JSON formatting is gone).

Userlevel 7
Badge +12

Can you share screenshots? 

This is using the POST webhook action or the Custom Request action?

Userlevel 1

You can find screenshots earlier in this thread. As described, POST webhook doesn’t work as expected, but custom request using POST does. How confusing...

Userlevel 7
Badge +12

Yes, I was able to get it working, but now the next challenge appears. The response is JSON, but it’s being returned as plain text (all JSON formatting is gone)

There are no screenshots of the response. Just of the request. 

The POST webhook action help text clearly states the data will not be sent as url encoded variables. If you wanted to try to use the POST webhook action instead of the custom request action i would try to put the variables in the URL i.e {{base_url}}?api_key={{key}}&image={{image}}