Best answer

New MYSQL Row not showing up


Hello,

I am trying to figure out why anew row didn’t trigger the ZAP.  I have it set to New ROW(Custom Query).  It test’s out just fine.

This is the code:

SELECT order_id, order_extra_val_1, order_extra_val_2, order_extra_val_3, order_extra_val_4, order_extra_val_5, order_notes, order_total FROM ms_orders 
LEFT OUTER JOIN ms_cart
ON ms_orders.order_id = ms_cart.cart_order
WHERE ms_cart.cart_pic_date_org = '2021 Level 3-4-5 State Meet' AND ms_orders.order_extra_val_4 = 'Friday Session 1: Level 5 Junior A & B Senior A'

icon

Best answer by Troy Tessalone 7 April 2021, 20:59

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

It did end up working, but took about 10 minutes.  Is that pretty normal?  Thanks!

Userlevel 7
Badge +14

Hi @jfreeman1412 

FYI: The MYSQL triggers are NOT instant, so depending on your Zapier plan the trigger can take from 1-15 minutes to fire.

 

I am having the same issue. 

It has been about 30 minutes. 

If the actual updating takes 15 minutes, what is happening when I hit “run” on the zap? It seems like it is checking realtime and saying “no new rows”, although one was just added. 

 

thx, 

rbv

Userlevel 2
Badge

Hi @Rakmun did you still need help with this?

 

When you hit “run” on the Zap it will run the trigger right away (so it will “look” for new data, in this case it will run your SQL query and try to find a new record that the Zap hasn’t seen before).