Question

New Lead in Facebook Lead Ads not triggering (but receives tests)

  • 18 October 2023
  • 5 replies
  • 108 views

Userlevel 1

Hello Zapmates!

I’m trying to integrate New Lead in Facebook Lead Ads to POST in Webhooks by Zapier.

 

In testing mode Zapier is able to retrieve Leads from Facebook to send the test and CRM is able to get POST event.

 

This means Zapier has access and permission to our Facebook Account in terms of Page, Ad Account and Lead access. Also, receiving test properly means that Ad form connected is correct.

 

It turns out when I activate the zap that New Lead in Facebook Lead Ads is not triggering. After receiving 55 leads, it didn’t triggered a single time. Yet, if I go again to test, it can find last leads acquired that hasn’t been retrieved.

 

Last but not least I’ve checked this https://help.zapier.com/hc/en-us/articles/8495982030861 and also this https://community.zapier.com/show%2Dtell%2D5/facebook%2Dlead%2Dads%2Dnot%2Dtriggering%2Dfor%2Dnew%2Dleads%2Dpulling%2Din%2Dsample%2Dor%2Dother%2Dissues%2Dhere%2Ds%2Da%2Dguide%2Dto%2Dhelp%2Dyou%2D18719#Page+still+not+showing+up?

 

What is happening? How can it be that it retrieves leads for test but it doesn’t trigger when the Zap is ON?

 

 


5 replies

Userlevel 7
Badge +14

Hi @Closa 

Good question.

To help us have more context, please post screenshots with how your Zap step is configured.

Also, post screenshots of the timestamps of recent leads in Facebook for the selected form.

Userlevel 1

I am having this same exact issue. Did you find a solution?

Userlevel 7
Badge +14

@almcknight20 

Help articles for using FB Lead Ads in Zaps: https://zapier.com/apps/facebook-lead-ads/help

I haveing the same issue too, since yesterday 12/12/23 ~12:30PM

I’m having this same issue and the tutorial doesn’t give any answers. 

We are losing leads because we can’t reply on time, please help! Otherwise I’m afraid we will have to find an alternative to Zapier Premium.

Reply