Question

MEWS - create order - Invalid JSON

  • 19 October 2023
  • 4 replies
  • 52 views

Hello!

I’m trying to create an order in MEWS but constantly get the error message “Invalid JSON”.

I created a test reservation in MEWS and checked in. 

App & event
I’ve tried the following options:

  • create order
  • add reservation product

Account

  • The MEWS account is connected and works fine. Test says there are no problems.

Action

  • Customer Id: I added the reservation number of my test reservation.
    Also tried to use a room number (I’d prefer this option, but I guess the reservation number is a must)
  • Service ID: succesfully connected the correct service from the drop down menu
  • Unique identifier of the Product to be ordered: succesfully connected the correct service from the drop down menu
  • Product Quantity: For now I added a fixed value of 1
  • Add Items: left blank as I’ve already connected a product
  • Consumption time: left blank. Also tried to add a manual date & time (within the time of the test reservation in MEWS).
  • Notes: left blank

 

Test result:  Invalid JSON.

 

Does anyone have an idea what I’m doing wrong?


4 replies

UPDATE: I replaced the reservation number under Action / CustomerID with the ID of MEWS’s guest profile for the test reservation.

Still got the same problem: Invalid JSON.

Userlevel 1
Badge +1

Hi @Roland M would you be able to provide some screenshots of your current Zap setup and error messages? Thanks

Hi @agileops 

I just had a chat with Zapier support. Looks like the settings are not the problem. There seems to be a bug on Zapier or MEWS’s end. Both supports are contacted. I’ll post an update if anything changes.

Thanks for answering and have a great day

Userlevel 1

yes

Reply