Question

How to map data correctly to remove field labels?

  • 3 November 2021
  • 13 replies
  • 453 views

Userlevel 1

Hello. I’m new to using Zapier and I have a question about the field mapping data that’s coming through on my Zap. I’ve created a webhook from a User Registration plugin on our website that creates a new webinar registrant in GoToWebinar once triggered. Everything is working fine but for some reason some of the mapped field labels are showing in front of the data that comes through. Like for City it will read City: CityChicago and on Zipcode it reads Zip68105. It’s also doing this on the phone number data like Phone: Phone+xxx-xxx-xxxx. 

This may be something dumb that I’m not doing but I wanted to check to see if there was a way to fix this so that the label field is removed and only the value/data comes through. I’ve attached a screenshot of what goes through to GoToWebinar. Everything looks fine in the Zap setup and doesn’t show the duplicate field labels.

I would really appreciate any help anyone can give me with this. I tried using the Pick Off Child Key but after re-testing and refreshing the fields it still comes through the same. Not sure if that’s the right thing to try or modify.

 

 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

13 replies

Userlevel 7
Badge +14

Hi @jtiams 

Please post screenshots with how your Zap steps are configured, thanks.

 

Either, the field labels are being sent from the trigger app, and thus you’d have to use either some Formatter > Text > Replace steps in the Zap to remove those field labels, or 1 Code step.

 

Otherwise, your Zap step config may have static values in those mapped fields, which should be removed.

Userlevel 1

You got it. I’ll include those for you here. Thanks!

This post has been edited by a moderator to remove sensitive information. Please remember to obfuscate any personally identifiable information prior to posting as this is a public forum. 

Userlevel 7
Badge +12

Hi @jtiams 

This is because in your Create Registrant action step, you have those fields set as “zip”+(mapping). Remove the the words in front of each field (such as zip, city, phone, etc) and you will be good to go!

 

If it helps in the future, think about these data mapping as a key:value pair, similar to a dictionary. If we were to look up the word “Example”. In the dictionary it would appear as “Example” followed up its definition. These data fields act the same way, we see “Zip Code” above the form field, that is the key in the dictionary, used to find the value, and the input we provide is the value, the actual definition of the key.

 

Hope this helps!

Userlevel 1

Wow. I feel dumb but thank you for your help. I typed in those to search for the correct fields to map and it kept my text in there. Thank you again!

Userlevel 7
Badge +12

Hi @jtiams 

No worries, we’ve all done it before! Glad I could help!

Userlevel 1

I have one more question about my setup. I’m getting an error message now that says that the GoToWebinar integration can’t import custom registration field data. I’m confused by this since the data is all showing up as coming through just fine. In my previous tests this morning it mapped a few of the custom registration questions just fine during the test. I was about to make the Zap live and tested again and got this error.

I went into GoToWebinar to make sure that all the questions were the same to match things up and saved the webinar. Restarted the test and refreshed the fields and I’m getting this error now.

 

 

Userlevel 7
Badge +14

@jtiams 

Error indicates either required fields are missing and/or fields have values longer than the max character limits allowed.

 

Userlevel 1

Can you let me know what the max character limits are or where to find that information? I can shorten the questions if I need to. All of the required fields came through so I’m guessing that may be the issue.

Userlevel 1

I’m guessing it’s from one of the last questions here.

 

Userlevel 7
Badge +14

@jtiams 

You may have to check the field settings in GTW

Userlevel 1

Hi Troy. We have daily webinars throughout the week and we’ve used the same registration questions for most of our webinars. They only limit the response/answers to 128 characters. It looks like all of the information is correct that’s coming through and the characters are under the limit for the answers.

 

When I clicked troubleshoot error in Zapier I got a message that said this “This is a known limitation at the moment. Right now, the GoToWebinar "new registrant" Trigger only has access to see non-custom fields on the trigger side.” Is that correct or am I able to import custom fields? I can always restart the Zap from the beginning and see if that helps. The data is all coming through and showing up for all of the fields so I’m not sure why I’m getting an error.

 

Any other ideas?

Userlevel 7
Badge +14

@jtiams 

I’d default to asking Zapier Support for confirmation: https://zapier.com/app/get-help

Userlevel 1

Thanks Troy. I think I’m going to just recreate the Zap from start to finish and see if that goes through. If I run into the error again then I’ll reach out to support. Thanks again for all of your help.