Best answer

Gravity Forms 2.4.24 & Zapier Add-on 4.0 - Unable to retrieve Forms

  • 15 April 2021
  • 4 replies
  • 110 views

Userlevel 1

I recently upgraded my plugins to the latest, but under Zaps, I could not retrieve any forms from Gravity Forms Wordpress, although I have many forms set up there. Not being able to retrieve forms cause me to not be able to setup the Zapier automation. 

 

Can you please advice?

 

 

icon

Best answer by Joseph C 17 April 2021, 03:56

View original

4 replies

Userlevel 7
Badge +8

Hi there @Joseph C - Thanks for writing to us! It looks like you may not be able to retrieve live data in this Zap. Sorry about that! There seems to be a workaround presented here: https://docs.gravityforms.com/using-real-form-entries-as-zapier-test-data/ - Could you give it a try to see if that helps you retrieve your forms?

Userlevel 1

Thanks for your reply Steph. I managed to speak with Gravity Forms to setup the REST API again. It works now. 

Userlevel 7
Badge +8

Hey @Joseph C - That’s awesome! Thanks for sharing that answer with the community. I’m positive it will help others. Take care!

Userlevel 1

For future reference, this is the link that helped me:

https://docs.gravityforms.com/rest-api-v2-authentication/#gravity-forms

 

When I re-do the Gravity Forms API, I was given a new Consumer Key & Secret Key. Inputting these to Zapier worked, and then I could find my Forms. 

Reply