Question

Format weird (nested) line items to proper line items

  • 15 September 2021
  • 3 replies
  • 78 views

Hi!

I used the webhook by Zapier and got the following data

 

I wanted to put the data in columns using google sheet / create spreadsheet row(s) but Zapier is not finding the line items because of the weird format as shown below: 

 

I guess I need to format it properly using Format by Zapier but I have not clue how to do this. I tried to remove the [] but it didn’t work. 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +14

Hi @Ramy 
What app is sending the webhook?

Perhaps the settings need to be adjusted in the originating app to avoid the nested line items.

Hi @Troy Tessalone !

I got the data from this end point https://api2.timedoctor.com/api/1.0/activity/worklog 

As shown below; I tried different settings of Send as Json and Unflatten but either it doesn’t work or its the same

 

Userlevel 7
Badge +14

@Ramy 

You may have to use a Code step to handle the JSON formatting with nested line items: