Cant figure out syntax for JSON payload with nested array

  • 11 June 2020
  • 1 reply


I am trying to POST a webhook to an application, and getting a ‘Invalid JSON’ error each time. 

I have narrowed the problem down to 2 fields in the payload, both of which only accept an array. I am only passing one value, but it still has to be in an array.  If I remove these fields, the webhook posts properly so I know it’s probably a syntax error or something. 

Here is the exact copy of the call that works when I post it using cURL:

POST /v2019-11/milestone-update/xxxxxxx HTTP/1.1


X-API-KEY: xxxxxxxxxx

Authorization: Bearer xxxxxxxx

Content-Type: application/json

Content-Length: 174


    "operation": "checkoff",

    "milestoneNumber": "1",

     "emailSend": "0",





I have tried putting this value in like [“<value>”] and also tried it with a custom payload. I can’t figure out the syntax! 

Can anyone help? I am stumped :)

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +12

Hi @Phar94954! Thanks for your question. 


I can see that you sent a message to the Support Team about this and that you were able to find the solution. If you have the time it would be super helpful it you could share your answer with the Community 🙂