Question

Authorize.net API Call giving error: There are multiple root elements. Line 1, position 51.

  • 12 October 2023
  • 0 replies
  • 60 views

Userlevel 1

I am trying to getCustomerProfileRequest from Authorize.net via a Zapier Webhook. I watched this video which was helpful to get me started. However, I encountered a handful of problems: 

Authorize.net Documentation on getCustomerProfileRequest: https://developer.authorize.net/api/reference/index.html#customer-profiles-get-customer-profile

  1. The Authorize.net API uses the same endpoint for all requests via POST. https://api.authorize.net/xml/v1/request.api.
    1. When I select POST. I’m not seeing how I can then tell the webhook to getCustomerProfileRequest. I also get the error code. “There are multiple root elements. Line 1, position 51.”
    2. When I select GET, I am not getting an error code but I am getting a magnifying glass that says “No Data Found”
  2. The Authorize documentation shows that merchantAuthentication is required in the Header, but the examples on the Authorize.net documentation show that name and transactionKey make up that data. I’m not sure how to get this into the Headers, to avoid the current error message.

 

I think the issue I’m running into is the XML formatting but I’m not a developer so not sure how to rectify this. Any help would be appreciated. (Data in screenshots left intentionally blank, but fields have info when I test the step.

 

 


0 replies

Be the first to reply!

Reply