Question

All variations of Webhook returning empty result

  • 6 September 2021
  • 1 reply
  • 329 views

Userlevel 1

I really wish zapier would show me the actual request and reply from the server. In a previous step, I pulled a list of dates for public meetings. In this step, one of those dates gets submitted and returns a JSON list of agenda items. It works great in cURL. Zapier? Not so much.

At first, I tried a standard POST hook with unflattening turned on. Well, it put the underscores in the API call anyway.

here’s what that returned

So I tried putting all the fields in a single “Keywords” item, like so: [{"ID":102,"Value":"9/21/2021","KeywordOperator":"="}] - which returned the same error.

So, the custom request was my next try.

Here’s what pops up for just a second while it makes the call

It looks good to me - but I can't actually see the raw request or the response. Here’s what I get back:

However, cURL returns what I need. Here’s a partial response below.

{"Data":[{"ID":"2013344","Name":"Agenda Item No. C01 - CC Agendas for Council Meeting of 9/7/2021","DisplayType":"OleActivePage","DisplayColumnValues":null},{"ID":"2013010","Name":…

What am I missing?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 1

I changed out the previous step’s response with a manual date I typed in. That’s working, so apparently there’s a problem with the way the previous step passes the dates (which look fine to me).

The step this morning is pulling the next meeting date - which is blank. Looks like I’ll have to iterate to the second response for testing purposes.