Zoom New Recording trigger now downloads files

Zoom New Recording trigger now downloads files
Userlevel 3

Hi everybody, Scott here from the Engineering team. I’m really excited to tell you that as of today the New Recording trigger on the Zoom integration allows you to download files to other services!

For now this only works on recordings that are not password-projected, so go to your Zoom recording settings page here and make sure the “Only authenticated users can view cloud recordings” and “Require password to access shared cloud recordings” settings are turned off.

 

The fields for the download URLs all end in “dl_urls” (e.g., audio_dl_urls, video_dl_urls).

 

These are line items fields, so if you stop and re-start recording during a meeting, they’ll behave like line items. If you only have one recording per meeting, though, they should work just like any other field.

Furthermore, this will only work for new recordings, i.e., those recorded after the Zoom settings above were set to “off.”

In anticipation of some users requiring this to work for password-protected recordings, we’ve added Feature Request #111 to Zoom.

As always, let us know if you have any questions or feedback!


64 replies

Userlevel 1

I’ve given this a go and been unable to pass this url to either vimeo → upload new file or google drive → upload file. In Vimeo I just get an invalid video file, which is no help. In Google Drive, I get an appropriately named file, but it is a small html file rather than a video file. Is there an extra step or another path I should be taking to get to the desired result?

Edit: I think I see what is going on here. You can copy and paste the url defined by video_dl_urls into a browser and it will initiate a download of an mp4 file through some magic, but it is not a true link to a file that can be passed downstream. If you look at the url you’ll see there is no file extension, and adding one doesn’t help. I lack the tools to see what happens after you paste that url into a new tab that leads to a valid file being downloaded.

Userlevel 7
Badge +10

Hi @JohnS!

I just tested this with an upload to YouTube and I can confirm that the file got there. Have you mapped the correct field, changed those options in the settings turned on the Zap and tested it that way? If you’re testing it in the editor with a recording from before those changes were made in Zoom, then it won’t work properly.

Is this the field you mapped:

 

Userlevel 1

Hi @nicksimard 

I have the same error when trying to upload to Vimeo … sadly!

I retested the upload to Dropbox instead … it did download from Zoom safely … created a zip file in Dropbox (which opened with correct mp4 files … so the upload does work in the end)

But it’s producing the “sorry, something went wrong” error when uploading to vimeo:
https://share.getcloudapp.com/p9uGKqb4

Is the problem due to it trying to upload more than one file (gallery view + speaker view files)?

(I can also confirm both the authentication toggles, per your screenshot above) were already switched off prior to the recording being made, so that part should not be the cause).

These are the fields mapped (ie the video files download URL, and a name chosen as the “start time”): https://share.getcloudapp.com/2NuyB4dp

I hope you can help, because this would be a very useful zap!

Thanks

Chris

 

Userlevel 7
Badge +10

Hi @ChrisG!

I hadn’t personally tested it with Vimeo so I tried that out, and I was able to get it uploaded as well. I did notice that your URL begins with https://us02web whereas mine begins with https://zoom.us. I don’t know if that’s any indication that you’re testing with a link that won’t work. You’ll want to make sure that the field you map there is only one link, and doesn’t consist of multiple URLs.

Also, you’re best to map the field shown above, skip the test to Vimeo altogether, turn the Zap on and then test it that way. When you do that you can be sure that the recording link will be one that was generated after those Zoom settings were changed.

I can confirm that it definitely does work, though :)

Userlevel 1

@nicksimard thanks for your reply!

Based on your successful test I tried a new approach - and this DID work, however …

in order for the zap to work it does (as you suggested) need just a single URL as the target.

But … in the “customize video” step in the Vimeo part of the Zap, there is no field which identifies just a single URL … there’s just a single field selector, which covers all the available urls.

My Zoom recording default is for speaker view AND gallery view AND screen share view - each of which I need on various occasions (hence setting as my default).

So … unless I’m missing something, I can’t automate this, as the only option available includes multiple URLs … is that how you see it too?

Here’s my demonstration: https://share.getcloudapp.com/4gu9ybDd

I appreciate your reply earlier - thanks.

Chris

ChrisG, can you pass through a Zap step that selects the appropriate link from the list? At worst, a Python or Javascript code step?

Userlevel 4
Badge

@shalgrim Well this sounds promising! 

I’m having issues with it still, though, in sending through a recording to YouTube. Can you see what I might be missing? Below is a screenshot of my “Customize Upload Video” fields and all I keep getting is an error message that says “The upload video could not be sent to YouTube. The app returned "Media type 'text/html;charset=utf-8' is not supported." 

 

Userlevel 1

ChrisG, can you pass through a Zap step that selects the appropriate link from the list? At worst, a Python or Javascript code step?

I’ve never done such things yet … relying on the tools & conditions readymade within the zap.

Maybe this task will need this extra coding … pity, though, as the use-case is standard?

Userlevel 1

@nicksimard following the post by @ChrisG regarding a single URL I reconfigured Zoom to make a single recording using “Record active speaker with shared screen” rather than multiple separate recordings. This appears to work as long as there is no chat log generated. So, the updated integration does work, provided there is only a single file available per session and no chat log.

I’m super pleased to have this working, thank you for your help. Hopefully in the future there will be a way to make this work where there are multiple files available.

I would like to follow Feature Request #111 if you’d add me.

Thanks,

John

Userlevel 7
Badge +10

Hi @ChrisG and @JohnS!

The most painless way to handle multiple recordings will be to use the Google Sheets method outlined here: 

Since those video recordings are line items, you can use the Google Sheets Create Spreadsheet Row(s) action (the one that supports line items) to create one row per recording. Then you have a second Zap that triggers on new rows in that sheet and in that Zap you have the Vimeo/YouTube/Google Drive, etc. step.

For example:

Zap 1

Trigger: Zoom — New Recording
Action: Google Sheets — Create Spreadsheet Row(s)

 THIS ONE

 

 

 

Zap 2

Trigger: Google Sheets — New Row
Action: YouTube — Upload Video

If you had 3 recordings when the Zoom Zap triggers, you’ll create 3 rows, which triggers your 2nd Zap each time

In your spreadsheet you’ll need a column for each possible field you’ll need to map into your upload step. Does that make sense? I know this isn’t the most straightforward thing, but given the way APIs work, you can’t upload multiple files in a single action step.

Userlevel 7
Badge +10

Hi @Brandi!

Have you tried mapping the field, skipping the test step for YouTube, turning the Zap on and testing it live? It may be the case that the link you’re using to test was created before you had those Zoom settings turned off. Or, try testing for a new sample on the Zoom step if you know you’ve got a recording that was made since you turned these off:

Can you give that a try to see if it helps?

Userlevel 3

Nick has things covered 100 here, but there’s one small piece I want to add @JohnS .

This appears to work as long as there is no chat log generated.

 

Chat logs should appear in the field `transcript_dl_urls`. Whether there’s a chat log or not shouldn’t affect the number of URLs in `video_dl_urls`.

Userlevel 1

Thanks, @shalgrim  I was encountering this error when I was using the ‘recording download’ url rather than the ‘video download’ url

Using the Google Sheets Create New Row(s) workaround works great. I can add to this spreadsheet from multiple Zoom Zaps and have a single Zap upload them to Vimeo.

I was unable to make this happen as a chain within a single Zap, but this works better anyway since I can consolidate all of the recording URLs into a single Sheet.

Userlevel 1

@nicksimard thanks so much - that G-sheet workaround solves the problem and makes it a very useful pair of zaps! 🙏

Userlevel 4
Badge

@nicksimard It’s working for me now! Thanks SO much!

Userlevel 7
Badge +10

@JohnS @ChrisG @Brandi So happy to hear that you all got things working :)

Userlevel 1

is this fixed for Google drive? I’m still seeing an HTML document instead of the recording :S 

Userlevel 3

Hi @Odeyk , 

During development I tested extensively on Google Drive. If you’re retrying with an old recording, or just any recording made before changing your Zoom settings you’ll still end up with that HTML document. Nick’s response to Brandi above is the same thing I’d suggest for you to try:

 

Have you tried mapping the field, skipping the test step for YouTube, turning the Zap on and testing it live? It may be the case that the link you’re using to test was created before you had those Zoom settings turned off. Or, try testing for a new sample on the Zoom step if you know you’ve got a recording that was made since you turned these off:

Can you give that a try to see if it helps?

Userlevel 1

Thank you! it worked now!!!

Userlevel 1

Hi @JohnS!

I just tested this with an upload to YouTube and I can confirm that the file got there. Have you mapped the correct field, changed those options in the settings turned on the Zap and tested it that way? If you’re testing it in the editor with a recording from before those changes were made in Zoom, then it won’t work properly.

Is this the field you mapped:

 

Thanks @nicksimard, this was the missing component for me.

Userlevel 2

Hi everyone! Im trying to export a Zoom recording to a Google Drive folder, but still cannot achieve that. 

 

This is how i configure the zap, but i only get a HTML file in Google Drive, or a plain text file.

 

 

Could someone tell me what i´m doing wrong? Or maybe i´m missing some something?

 

Zoom recording configuration has this settings disabled:

I understand, after reading this topic, thats possible to achieve this.

I hope that you can understand my question (english its not my native language).


Thanks in advance!

Regards!

Hi @shalgrim 

It seems everything was correctly set but I'm still getting no video on Vimeo.

 

https://jmp.sh/0F0njzf

https://jmp.sh/9iJ5lEj

 

On Vimeo we keep getting this: https://jmp.sh/9N5GnZq

What could be wrong?

Thanks.

Userlevel 3

Hi @taller_dig ,

 

Have you tried skipping the test step for Vimeo, turning the Zap on and testing it live? It may be the case that the link you’re using to test was created before you had those Zoom settings turned off. Or, try testing for a new sample on the Zoom step if you know you’ve got a recording that was made since you turned those settings off.

@shalgrim thank you for your prompt answer.

The last one was made with the new settings but I didn't rebuild the Zapier trigger. I was wondering if those settings were OK and having your confirmation, I'll try to rebuild the trigger. I'll let you know as soon as I run the tests.

Userlevel 2

Hi everyone! Im trying to export a Zoom recording to a Google Drive folder, but still cannot achieve that. 

 

This is how i configure the zap, but i only get a HTML file in Google Drive, or a plain text file.

 

 

Could someone tell me what i´m doing wrong? Or maybe i´m missing some something?

 

Zoom recording configuration has this settings disabled:

I understand, after reading this topic, thats possible to achieve this.

I hope that you can understand my question (english its not my native language).


Thanks in advance!

Regards!

Solved!!!! It was a permission error in Zoom recordings. The item marked in the screenshot has to be enabled in the recording sharing configuration: 

I post it here in case that can help somebody with their troubleshooting.

 

Thanks all for your help!!

Regards!!

Reply