How to troubleshoot your Zaps

  • 1 October 2020
  • 0 replies

Userlevel 7
Badge +11

We try to make Zapier as easy to use as possible but there are times when you’ll run into errors with your Zaps. This can be for a variety of reasons, including but not limited to:

  • A misconfigured Zap
  • Missing data in a step of your Zap
  • Zapier-related issues
  • Issues with the app partner/integration
  • Hitting API limits and being throttled

Here are some troubleshooting tips to get you on your way as quickly as possible: 

If you post your error in Community, please be descriptive and include the error message if it is available

Instead of: “My Quickbooks Zap is broken- HELP!”

Try providing some context so that you receive better, more timely assistance: “When I test my QuickBooks step in the Zap Editor I get this error message:”

If your error is in the Zap editor, use the built-in help guide:

If you look at the screenshot above, you’ll notice that there’s a button that says “Troubleshoot Error.” By clicking that button, the Guide will open on the right-hand side of the editor:

Check out the “Troubleshoot errors in Zapier” doc:

If one were to scroll down in the animated GIF above, they would see this:

Clicking “Troubleshoot errors in Zapier” will open up another document that you can check out:


In addition to that (or if you’re not in the Zap editor) you can visit our help docs section about troubleshooting:

Troubleshoot Zaps | Help & Support | Zapier

Take a look at the “Common Problems with [app]” help docs:

Sticking with our QuickBooks example, here’s how to see which common problems (if any) exist with your particular app’s integration:

Search the Zapier Community for the error message you’re experiencing:

Before posting in Community, it’s good idea to do a search for the error message you’re seeing. If there’s no message, then use keywords that you think others would use if they were going to post about the problem.

That way, if you do find a topic in Community, it may have already been solved. Or, if it hasn’t been solved you can create a new topic and link to the one(s) you found.

Consider creating a new topic rather than adding on a “me too” in an existing topic. If appropriate, we can merge topics after the fact. 

Try using your favorite search engine to see if it’s common, or if it happens more generally:

Sometimes, the error message you’re seeing is not unique to Zapier and has already been documented elsewhere online (including in that app’s own help docs). 

You can save yourself a lot of time by seeing if someone else has already figured out what the error means and how to fix the problem!

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.