How to Troubleshoot 5 of the Most Common Zap Errors

  • 10 September 2022
  • 1 reply
How to Troubleshoot 5 of the Most Common Zap Errors
Userlevel 7
Badge +11

Hey Zap fans! I’ve got something special for you today :)

This content was originally created by two automation experts, Mike Cardona and Daniel Bustamante, over on their Busy to Leveraged blog. It’s part of their Intro to Automation 101 course.

Their original title was How to Troubleshoot The Five Most Annoying Zapier Errors but I tweaked it a bit 😜

With their permission, here’s their blog post. Be sure to check out their blog as well.

As you're probably starting to realize, automation is amazing.

BUT… It's not perfect.

And when you're starting out, you'll inevitably run into bugs - just like we did. Which can be frustrating if you don't know how to deal with them!

Today you’ll learn how to troubleshoot the five most annoying Zapier errors.

Let's dive into it.

Annoying Zapier Error #1: Your Zap won't trigger

Sometimes your Zap won't run as expected. When this happens, the first thing you want to do is make sure it's being triggered.


  • Go to the left hand side of your Zapier dashboard and click on "Zap History."
  • Once you're on the "Zap History" page, click on "Zap Runs."
  • If your Zap is running properly, it should show up there as a "Successful" run. If not, it's because it's not getting triggered.


To fix this issue, try these 3 steps:

1. Go to your Zap and make sure it's turned on:


2. If it is turned on, click on the Zap to go into the editor and retest both the trigger and the action steps of your Zap:


3. Still not working?

  • Make sure you're using the right accounts for the apps involved in your Zap
  • If you are, try disconnecting and reconnecting your apps back.

If none of these help, check out these recommendations by Zapier.

Annoying Zapier Error #2: Zap paused and not running

Sometimes you create a Zap, you turn it on, and then you close your browser thinking you're done.

But when you come back, you realize your Zap hasn't been running.

"What the heck!?"

This problem is typically created by one of these 3 reasons:

  1. Your Zap ran into an error too many times in a row
  2. Your Zap uses a pro feature that's not included in your current plan
  3. You ran out of tasks for this month

To solve problem #1, check the task history of your Zap so you can get more details on the error.

To solve problem #2 and #3, you'll have to upgrade your plan (or wait until the next billing period so you get more tasks!).

Annoying Zapier Error #3: Incorrect Zap dates or times

Dealing with different time formats and time zones can be confusing - especially at first!

And sometimes the apps you're working with won't display a date or they will but in an incorrect format.


To fix this:

1. Go to your profile settings and make sure your time zone settings are correct. 


  1. If the time isn't off by a lot then it could be an issue with an incorrect format (if you're typing the date by hand).
  2. Sometimes the date formats of different apps are not compatible. So if you're using a dynamic field to map your date (if the date is being pulled from a previous step), then you might need to use the Formatter step.

You can learn more about date formats here.

Annoying Zapier Error #4: Zap not sending any data

Sometimes your Zap might seem like it's running perfectly but the action is still not being completed.

The problem? It isn't sending any data. This is a common bug when you're building Zaps involving media files.

To fix that, go to your Zap editor and make sure your fields are properly mapped.


Still not working? Go to your Zap History and check if it's pulling empty values


If you see a bunch of curly brackets in your Zap task history, it means your Zap is indeed pulling empty values. Check out this resource to learn how to fix this issue.

Error #5: Zap stuck in a "Loop"

Lastly, the infamous "loop."

A "loop" is when one of your Zaps run over and over again from a single trigger event - until they suck up all your tasks!

This typically happens when you have two Zaps that trigger each other.


This typically happens when you have two Zaps that trigger each other. For example:

Zap 1:When a new contact is added to Salesforce, create a new contact in Google Contacts.

Zap 2:When a new contact is added to Google Contacts, create a new contact in Salesforce.

Or when the trigger and the action of a Zap are the same:

"Looping" Zap: When a new contact is added to Google Contacts, create a new contact in Google Contacts.

This ends up unintentionally firing off Zaps and eating up your tasks.

When this happens, you need to update a field in both of your "looping" Zaps and then create a filter. You can find more detailed instructions here.

And that's it!

Check out the original blog post here on Busy to Leveraged.

1 reply

Userlevel 7
Badge +14

When in doubt, check the Zapier Status page: