Best answer

My Zap is not letting me choose the office email as a field, just the company name and domain.

  • 23 May 2022
  • 8 replies

Userlevel 1



I am using an integration between Affinity and Zapier.

I want to send emails after the status of a certain company in the Dealflow changes in Affinity.

The problem is that Zapier is not letting the office email as a field to be chosen, just the company name and domain.

  1. If the company comes through our submission in Typeform, it is ok, I can make a lookup in typeform and I find the email.
  2. If the company comer from adding manually and they only input the email in the office email field. I can’t get the email.

Is there any other way to solve this?


Thank you.


Best answer by christina.d 3 June 2022, 22:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +8

Hello again @Michael_CalmStorm! Thanks for coming here to ask this question. 🙂

After your trigger step in the Zap, are you able to insert a “Find Organization” step to see if that is able to grab the “office email” for use in later steps? I am wondering if there is a "Find” (search) action for Affinity that you can use to access this information. You might have to play around a bit to see which one (if any) allow you to grab this field.
Let us know if you’re able to get this working in the way you’re needing!

Userlevel 1

I have a step to find the organization, but is not pulling the email information from there.

I even inserted a lookup responses in Typeform, but now is not even pulling the typeform. This test was successful last week, but now I can’t get the emails from the organization or the typeform.

Is there something else I’m missing?

Thank you

Userlevel 7
Badge +8

@Michael_CalmStorm Ahh, thank you for confirming. So, is the email address associated with an organization? Or is it associated with a contact within an organization? Looking at some of the data for those Affinity action, I am seeing it was built to pull a domain but not an email address when searching for the organization. However, finding the organization returns the IDs of associated contacts, which you could then use in a subsequent “Find Person” action. 

Note: Doing this may sometimes lead to finding multiple contacts, you you’ll need to decide how you’d like to handle multiple email addresses.

I’m not sure what you mean when you are referring to the lookup within Typeform. Are you able to share some screenshots so I can better understand?

Userlevel 1

Hi! Thank you for your response.


Let me explain the workflow - company submits information and pdf file from Typeform - Zapier relocates the answer to each column/field in Affinity. One of the informations is email, where we place in Office emails.

For this Zap, once this company has it’s status changed, I wanted to send them an automatic email. So the status “Reject (no call)” would be the trigger.

When I tried to pull the Office email from the Step: Find Organization, it can’t be pulled, it just shows company name, company id in Affinity, just the information created by Affinity and not the information from the organization’s profile. That’s why I tried to find the company in the Typeform and get the answers from there. Which worked last week in the test, but it does not work anymore, for some reason.


I tried to look for asnwers from the company name and the day that the company was created in Affinity (lists entry created at) and not the status date. They are created in one day and the status Reject (no call) is created days/weeks later.


Is there any other way to try to get their email?

Thank you!



Userlevel 7
Badge +11

Hi @Michael_CalmStorm

I can’t think of another way of getting the email address from Affinity, but I’d like to try and figure out why the Lookup Responses step is now failing. Are you getting an error or is it not finding something that you know exists? 

Userlevel 1

Hello, thank you for checking in.

Here is the screenshot. It can’t find the correspondent typeform. Even though I fulfilled the typeform myself in the same day of the test. 


Userlevel 7
Badge +11

Thanks for sharing that screenshot @Michael_CalmStorm


The 400 error is interesting because (as the help text says) we often see that when the Zap sends data in a format that the receiving app wasn’t expecting (eg we send a number instead of a text field). I would reach out to the Support Team on this one. They will be able to look at the logs for the Zap and the Zap itself to see why we might have received that error and what needs to be changed to make it work the way that it should. The best way to contact the Support Team is with Get Help Form.

I’m sorry that we could get to the bottom of things here, you can include a link to this conversation in your ticket to Support so that you don’t have to cover the same ground with them. 

Userlevel 7
Badge +9

Hey there, @Michael_CalmStorm! I took a peek and can see you were able to get the look up test working on your own, which is amazing. Do you recall anything specific that changed? We’d love to know!

If it’s at all helpful for anyone following along of the recommended troubleshooting steps in the ticket were to:

…confirm that for the test record in place, within Typeform, for the form "Calm/Storm Ventures Application", there's a form response that contains the email ""?

from there once they were able to confirm the test was working the next recommended step was to:

...insert a Formatter by Zapier step after your find step using the text.extract email address function to parse that address so you can pass it to your Gmail step.