Best answer

Is anyone else having issues with Google Ads Offline Conversions timing out?

Userlevel 1

So, I’ve been having problems with the Google Ads Offline Conversions integration.  When I submit my test data (which I know to be correct, as it miraculously worked once and never again) I am getting a messaage that Openresty has timed out:


The data I’m passing across is good data - the integratino did work once after repeated attempts to test that step… this is the data…


Is this a known problem? I can’t see any issues on the Zapier status page that might cause this? I’ve messaged support and am awaiting a response...

Any help GREATLY appreciated.

Thanks, Ross.


Best answer by christina.d 2 September 2022, 23:53

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

23 replies

Userlevel 7
Badge +9

Hey there @ukrossco - thanks for sharing this! I’m sorry to see you’re coming across this error!

The only thing I can think of is perhaps is the quantity of the leads coming through resulting in the timeout?

Outside of that though, it might be worth hanging tight to see what our friends in support have to share! They’re able to dig into the logs and may be able to provide a bit more insight. Definitely keep us posted on your findings though!


Userlevel 1

Hi Christina

Support came back and said that this is indeed a bug and I can see that the timeout on this has been extended to try to prevent it failing.

Unfortunately, a second issue has now appeared. As the timeout has increased, the step fails but does not return to zapier a success or failure message, it just times out.  I’m guessing that the actual Send Offline Conversion remains in a queue somewhere in the backend and is eventually successful. 

This sounds great, but it introduces a second more serious problem: Zapier sees the timeout as a failure and reschedules the step which would seem the sensible thing to do.  In the time between this failure and the reschedule run time, it seems the ‘Send Offline Conversions’ step is actually successful having been queued somewhere outside of the zap runtime. This means that when the rescheduled step runs, the step returns an error of ‘gclid/timestamp already exists’ and zapier reschedules the step again. 

The problem is that once this duplicate gclid/timestamp error has been returned from the step, it will always return this error which will always result in the step being rescheduled. The result being that the ‘Send Offline Conversions’ step becomes an infinite loop of reschedule/error/reschedule and these loops need to be killed off manually in the ‘Zap Runs’ screen. Because the loop occurs within a single step, there is no way to handle the failure.

My suggestion would be that the duplicate gclid/timestamp error is reclassified as a warning or advice and assigned as an output to the step in order that the step can proceed and this situation can be handled by subsequent steps in a zap rather than forming an infinite loop.  Sometimes when dealing with complex marketing scenarious, duplicate gclid/timestamps do occur and I would say that the detection of these is a success rather than a failure of the step.  After all, it has done its job rather than failed outright. Much in the same way that when searching for spreadsheet rows, the step can still be considered a success even if none are returned.

I think it’s also worth noting, that last week the step was taking 20 - 60s to return a successful ‘Send Offline Conversions’.  This week it is taking in excess of 180s and I wonder if this might be due to the additional load brought about by this reschedule/error/reschedule loop where duplicate gclid/timestamps exist (and particularly since they now appear to be being actioned even after this step has timed out).

I’m in touch with Sydney in support and have emailed across my suggestions - hopefully we can get this fixed ;-)

Many thanks


Userlevel 7
Badge +9

Hey @ukrossco! Thanks for letting us know. I caught up on your thread with support and do see the related bug for this. We’ll make a note that this thread is related and post any updates we have on that specific bug here as well, for anyone else following along.

In the meantime, I wanted to share this helpful workaround from @cschimoler:

After some trial and error I have been able to work around this issue, if you work from Google Ads to Zapier it seems to cooperate. 


I had success by creating new conversion events in google ads and continuing to zapier through the hubspot integration there. 


Not sure what difference it made or why it would change anything but I have have been able to replicate several successful offline conversion events with this approach. 




Userlevel 7
Badge +9

As for your second question/feedback, I want to first thank you for taking the time for writing such thoughtful suggestions. It’s certainly helpful for our product team to consider when making changes to the functionality of our platform.

I noticed you shared some of this feedback on your email thread with support, who replied to you and said:

Thanks for following up and providing this additional insight! 
I will say, the Zap will never get caught in an infinite loop of retrying errored Zap runs. Zapier backs off after each successive failed retry attempt, on this schedule:

  • 5 minutes
  • 30 minutes
  • 1 hour
  • 3 hours
  • 6 hours

This means that if the Zap run errors at 1:00 p.m., Autoreplay will try again at 1:05, 1:35, 2:35, 5:35, and 11:35. The back-off schedule implies the final retry happens approximately 10 hours, 35 minutes after the first error. Although this isn't an infinite loop of retrying the error, it does cause any actions that depend on the steps output to not run as expected. 
In regard to the Zap interpreting the duplicate glcid/timestamp error, I can see how it would be valuable to continue on in the Zap given the bug that causes the error. However, this isn't exactly the same as a Zap Halting and being able to continue when we do not Find a record. In this case though, we get an error when trying to create a record, and albeit because of a bug, it is still expected behavior that the Zap would error in this case. 

If you have any other feedback/questions about this, continuing to follow-up on that support thread is going to be your best way forward. 🙂

Userlevel 1

Hello - 

It seems this error has entirely broken the Google Ads integration with offline conversions. 


I am unable to successfully create / send any new zaps involving offline conversions with Google Ads. 


The 504 error occurs every time when trying to complete the offline conversion in testing. Which locks the zap into a draft and does not allow me to publish.


Even when I duplicate zaps that are successfully submitting offline conversions to Adwords - The steps are identical, yet the old zap successfully passes & the new zap fails. 


This is completely halting our marketing efforts - I cant find a definitive solution to this anywhere. 


Any help would be amazing!

Userlevel 1

After some trial and error I have been able to work around this issue, if you work from Google Ads to Zapier it seems to cooperate. 


I had success by creating new conversion events in google ads and continuing to zapier through the hubspot integration there. 


Not sure what difference it made or why it would change anything but I have have been able to replicate several successful offline conversion events with this approach. 



Userlevel 7
Badge +9

@cschimoler Oh this is wonderful news! I will update the best answer here with your workaround. Thank you for coming back into this thread to share and help others! 🙌

Userlevel 1

@ukrossco Did you manage to find a way around this yet at all?


I’ve seen @cschimoler ‘s suggestion, but as we’re not using Hubspot I don’t think this will work for us.


Next optoon is to call a Python code step, but keen to avoid that if at all possible.

Userlevel 1

I’m running into this issue, albeit adding Klaviyo Profiles to Google Ads Customer Match Lists via email.

The setup on the Google Ads side links you to Zapier when you select that option, and testing worked originally. Out of 15 emails attempted to be added, only 5 have been successful. The data size should be the same for each request - it’s just email.

This is really disappointing considering both Zapier and Google are promoting this integration as available, but seems like it is at best inconsistent and at worst, unusable.

Userlevel 7
Badge +12

Hi @ross.hopkins, I’m really sorry that you’re having this trouble with your Google Ads step. 

The team that handles this app is looking into the issue and I’ve added you as an affected user on the bug report, which means that we’ll send you an email when there’s an update. In the meantime, I can only apologize that the integration isn’t working the way that it should. 

I have this same issue. Timeout error when attempting to test the action.

@Danvers Somewhat related to this thread: Are there any plans to implement the “Send Call Conversions Google Ads”? (Currently you support Click Conversions via GCLID and Enhanced Conversions via Phone or Email, but you do not support Call Conversions via Phone (different than Enhanced Conversions)).



Userlevel 6
Badge +3

Hi @aczarto 


I’ve added you to the list of affected users. We’ll update you via email once an update is available.

Userlevel 1

I have this same issue. Please fix it as soon as possible! Thanks

@jammer.solijon same problem here, constantly 180 sec timeout error on google ads offline conversions… can we get an ETA when this is fixed?

Hi There,

My offline conversions back into Google Ads keep timing out.  Is there anyway to fix this?


Failed to create an offline conversion in Google Ads

<html> <head><title>504 Gateway Time-out</title></head> <body> <center><h1>504 Gateway Time-out</h1></center> <hr><center>nginx</center> </body> </html> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page -->

show more

Userlevel 1

Hey all, 

While we wait for a fix for this bug, I think I’ve found a temporary solution for uploading offline conversions to Google using a google sheets flow and Google ads’ scheduled upload feature. My Zap looks like this: 


  1. Trigger: Updated field on salesforce object
  2. Filter: Google Click ID must exist 
  3. Delay: 24 hours
  4. Add new row on google sheet

It’s important to make a google spreadsheet with the headers you require first. You can download a template from google ads under tools & settling → Conversions → uploads → click the plus button, then you’ll see “view templates for formatting your fields.



In the Google sheets template, you’ll see a “parameters” field. It’s important to remove this when you set up your Zap. You will be adding it in later once the zap is running.


Once you have the desired headers on your google sheet, set up your Zap and map the data you want passed through from your CRM to your google sheet headers. Once information is being passed through successfully, go back to your google sheet, insert a row above row 1 and put your parameters field back in - you’ll set the time zone for your conversions here. The spreadsheet should look like this (depending on your time zone): 



From here, go back to google ads and upload a google sheet from the “select source” drop down. Make sure your google sheet is shared with the email address that will appear on the screen in you google ads account. Connect the google sheet that you put together (I waited until Zapier populated the sheet with at least one conversion so that I could QA and make sure everything was operating correctly). Click “preview” in google ads and the platform will show you what the results of your upload would have been if you sent it through. If you get a success message then you’re good to go! If you get an error message, then investigate (I kept getting an error message because my parameter time zone was not set up properly).


Once you’re happy with the results of the upload, move to the “schedules” tab in Google Ads. Set an upload from that sheet to occur every 24 hours at your desired time. Note that each day, you’ll get a certain amount of successful uploads and a certain about of errors. This is because google will be uploading the same sheet every day so the conversions that have already been uploaded will error out. Just make sure the check the error logs every so often to make sure that is the only error type happening. 


I’ve had this Zap running for the last few days and it looks like its working well. Feel free to send me a message with any questions. 



Userlevel 6
Badge +3

Hi kpidan, MISCH, and Ro Ahuja,


I’ve added you guys to the list of the affected user, and we’ll update you via email once this fix is implemented. Thank you, Matthew.Harrisfor this awesome workaround. Kindly try this temporary fix that he mentioned and let us know if that works. 

Userlevel 7
Badge +9

Wow, @Matthew.Harris! 🤩This really is incredible!

We can’t thank you enough for sharing this with the Community.

Hi @jammer.solijon Could you please add me as well? Same issue here.

Userlevel 6
Badge +3



I'm sorry to learn that you are also encountering the same issue. I've added you to affected users, and we'll update you via email once available. Thanks!

Have the same issue, could I please also be added?

Userlevel 6
Badge +3

Hi @AT JumpStory 


I’ve added you to the list of affected users and we’ll email you an update once available. Thank you!

Userlevel 7
Badge +9

Hey all! I wanted to stop in and mention our team pushed a fix and this bug is now closed! 

If you’re still running into this, please open a ticket with our friends in support and they can dig into this a bit more. 

Thanks so much for your patience on this one! 🙏🏽