Best answer

Unable to authenticate Moodle - "Error code servicenotavailable" error

  • 7 July 2021
  • 2 replies
  • 668 views

I saw a couple of posts with the same error but they don’t seem to have been resolved. Would appreciate any help.

icon

Best answer by SamB 7 September 2021, 16:45

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +14

Hi @rbs 

Try authenticating in a new private browser.

Or you may need to open a ticket with Zapier Support: https://zapier.com/app/get-help

Userlevel 7
Badge +11

Just wanted to follow up here as it looks like there is a known issue with the Moodle integration that might be causing that “authentication failed: Error code servicenotavailable” error. This same error is discussed in a related thread here: 


There are a couple of things noted on that thread that are worth checking: 

  1. Can you please check if Mobile Web Services is enabled in your Moodle account? To enable them: in Moodle: Access Administration> Site administration> Advanced features > Check 'Enable web services' then click 'Save Changes'
  2. Can you let me know if you you're using a cloud-hosted version of Moodle or if you're using a self-hosted version? If it's self-hosted, what version are you using?


If Mobile Web Services are already enabled and self-hosted version 3.8.3+ is being used then it is likely that the Zap is running into a known issue with the Moodle integration.

For anyone that may be running into this same error I’d recommend reaching out to our Support Team via the Get Help form. They will be able to check the logs for your account to confirm whether you’re running into that issue with the Moodle integration and add you to the bug report as an affected user if needed.