Best answer

Trello and Google Sheets Question

  • 4 February 2020
  • 3 replies

Userlevel 1

Not sure what's going on here so hoping someone can help me.

I have a Zap set up to create a new Trello Board upon the creation of a new row in my google spreadsheet. Tested it, worked perfect. Added my first new row to Google Spreadsheet and it set up the board perfectly. All good here.

I have an additional Zap that @AndrewJDavison_Luhhu helped me set up that looks up that Trello board board ID and then adds cards to that board based on new rows in another tab within my spreadsheet. That was tested and worked perfectly.

Now here is my problem: We input a new project into our system on 1/28/20. Trello built a new board from my Zap and everything looked perfect. However, before any cards could be created for this board, someone edited a single cell in that new spreadsheet row. No new row was added from this action, just a change to one of the cells within the row.

After the cell change, the zap that creates the boards triggered again. It created a new board that Trello assigned the same ID number as the previous board, except all the information turned to N/A. I realize the ID number comes directly from Trello and is the number Trello expects to be returned by Zapier. What I don't understand is why a change in a single cell caused the Zap to run again. Did I missing something? The Zap is supposed to trigger up a new row in my google spreadsheet, not a change to a row.

Any advice would be greatly appreciated.


Best answer by steph.n 31 March 2020, 20:03

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +10


So speaking broadly, on or around the same time the cell value was changed, did you happen to delete, rearrange or add a row inbetween existing rows - and/or did any columns get added or re-arranged?

It sounds like no, but the things I just listed are often the cause of erratic behaviour with Google Sheets triggers.

If not, it's best to contact Zapier support as they'll be able to zero in on the logs for when that triggered and should be able to tell you exactly what/why it did. You can open a ticket here:

Good luck!

Userlevel 1

I DID work on my google sheet late last week, but I went in and turned off all the Zaps while doing so because I have several that trigger from changes on that particular spreadsheet. Since I didn't catch the issue for several days including thru Super Bowl weekend (in Kansas City), I'm not I'm confident enough to say 100% I didn't cause it.

I'll set aside some time today to try to recreate the issue and see what happens. I appreciate your input/guidance on it. I'll open a ticket if I cannot recreate it.

Userlevel 7
Badge +8

Hey @TOPCM - I saw that you submitted a support ticket, but wanted to make sure that the answered is shared in case any one else is looking for the same:

Hi Michelle,

Thanks for reaching out to Zapier, I hope you're doing well today! Sorry you're having trouble with your Zap. Jamie from Support, happy to assist!

Wow, yeah, this is a really strange issue. I can see from in your Task History where we're correctly passing along the Board ID found in Step 2, but the data we receive back from Trello shows that the card was created on the board. Really weird!

Alright, let's try something real quick. Would you mind clearing the current choice for the "board" field in Step 3? 

(view larger)

Once you've cleared the choice, go ahead and reselect "Use a Custom Value" and set up the mapping again. What I'm looking to test here is whether or not there's a strange caching issue with your Zap.

Give the above a try and let me know how it goes! Please let me know if you hit any snags or have further questions. I'm happy to dive back in and take another look.

Fingers crossed,