Best answer

Strava API Distace in K issue

  • 3 January 2021
  • 2 replies

Userlevel 1

hi everyone,

I set up a simple zap between Strava and GSheet

whenever I record an activity on Strava I want to get some parameters on a new GSheet row.

one of these parameters is “Distance in K” (total distance in kilometers).

the problem is that it randomly changes in a strange <1 decimal number.

for example: I record a 14.2 Km run but the value I get in gsheet is something like 0,59

if I try to trigger this action (several times) in test mode from Zapier (Retest & Review), I sometimes get the right value in K

please note that the spreadsheet where I send the data is clean and I didn’t apply any weird cell format.

is there anyone who can help me fix this out? 



Best answer by anybigidea 5 January 2021, 14:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +10

Hi @anybigidea 

Can you show us a screenshot of how you’ve got the Google Sheets step configured in Zapier.

Userlevel 1

hi @AndrewJDavison_Luhhu !

thanks for the support.. I just solved the issue.

it was basically a decimal separator problem between strava, which uses the “.” and my gsheet, wich is set to use “,”.

so whenever strava sent data, gsheet interpreted it in a time format (eg. 14.19 > 14.19.00) and subsequently tried to translate it in a number format (eg. 0,59).


since I have lots of data and other calculations on my spreadsheet which involve the decimal separator misalignment, I solved the issue with a substitute() function.