Best answer

Pinterest account is "expired". I can't reconnect it.

Userlevel 1

Hi, I have a problem with Pinterest automation — everytime when I reconnect it, Zapier announces me that “Pinerest account is expired”. Any ideas on how to solve this problem? Thanks in advance!



Best answer by steph.n 19 November 2020, 19:19

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

46 replies

Userlevel 7
Badge +8

Hi @zaxarov ,

Thanks for reaching out- sorry you are running into this error here!

I see you are working with Support on this issue, so I will let them dig in and troubleshoot. Please let us know if you have any additional questions!

I’m having trouble logging in to Pinterest with Zapier (paid account) for a few days. Everything worked fine before. At the moment I receive the information: “Pinterest zbysiusp1. This account is expired. Please reconnect it hereI can't reconnect it. The Pinterest account I logged in with isn't suspended. Please help me to solve  problem. Best regards.


Userlevel 7
Badge +10


I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +8

Hey @zaxarov and @avrfun - I see that KC from Zapier Support replied back to you. Could you please let me know if you have a Pro/Business Pinterest account linked to your personal one? If so, you will need to create a separate pro account to be able to connect it to Zapier.

If this isn't the case, it looks like you may be running into a bug we are tracking. We've seen a spike in the number of these errors. However, that seems to have been intermittent and it looks like Pinterest servers are getting back to normal now. Please let me know if this is the case and I'll add you on the list of affected users. You will receive an update as soon as this is fixed.

Please let us know!

Hey. I still have trouble connecting to Pinterest through Zapier (paid account). Everything worked well for a few minutes, and now the already known message appears again (This account is expired).  I've made 8 calls from different Zaps at the stage of their creation. Pinterest informed me that the account I logged in with isn't suspended. I am desperate because I can't work. I'm struggling with the issue all the time. I tried to connect through other accounts but to no avail. I think I have to give up. Kind regards. Avrfun.

I’m having the exact same problem. My Pinterest account is a business account I created separate, why is this happening? My Pinterest account is not suspended and when I try to connect it to Zapier I get the error message that the account expired. Can someone help me??

Facing the exact same issue here too. However in my case it's a personal pinterest account which worked perfectly when testing. Now when the time came to go live, it refuses to connect no matter how many times I try to reconnect it. Account's working fine in app and on browser. To be really honest, it does not paint a good picture for someone who came to the platform first time to test it's capabilities. Hope this resolves soon.

Userlevel 7
Badge +8

Hello @avrfun, @caribeconnection, and @Jaykay

Our Support team has provided the following answer:  

Looks like Pinterest is giving us the authentication error because of a rate limiting issue. Pinterest has enacted strict limits to the number of times each day that we can make requests to their systems for new data. Whenever the limit is reached, they will return these error messages. There isn't much we can do about this as the limits have been set from their end.

This change can also be found here on Pinterest’s developer doc:

Hi @steph.n ,

Thank you for responding.

Hope you are doing well.

Quoting from the site:

Effective April 29 2020, all unapproved apps can only make 1 call / hour against the developer API. Each approved app (with a unique appID) can make 100 calls / day for each unique user token. Both windows of time are sliding windows. If you hit your rate limit, you'll have to wait a minimum of 1 hour to get a few more requests.


In my case Pinterest was accessed (zapped?) only once via Zapier which was successful in the morning. It was late in the night (more than 10 hour delay) when we tried to activate the zap that we started facing the issue and it is yet to resolve. I believe it should be closer to 24 hours now but the Pinterest account is still not connecting.

 Please do look into this as I believe what you are suggesting is not the case here.


Userlevel 7
Badge +8

Hey @Jaykay - It’s been a while, and I wanted to check to see if this issue is still persisting for you? We haven’t found any new updates or changes, but we wanted to see if you were still experiencing this same issue. 

Userlevel 1

This is still happening. If you go back to the link page and try to relink you will see that it fails, and shows this message. Looks like Zapier as a platform needs to get special privileges from Pinterest otherwise it will be useless as the more users use the integration the sooner API thresholds are met in the morning. 


Userlevel 7
Badge +8

Hi @MSadeghi ,

Thanks for letting us know and so sorry you are encountering this error! I see that Shalyn in Support has added you as an impacted user of this bug, which will ensure you are notified when it has been resolved. 

We do not have an ETA on this fix, but I do see that the team is actively working on it. I know that’s not the answer you had hoped for, but please let us know if you have any additional questions!


I also encounter the “You have exceeded you rate limit” problem after very moderate usage. Any solution in sight?

Userlevel 7
Badge +12

Hi @Swedenborg, I’m sorry that you’re running into this issue with your Pinterest Zaps.

We’re still looking into this one and I can see that Clint from the Support Team has already added you to the list of affected users, which means that we’ll send you and email when we have an update. 

Userlevel 1

Hi, I’ve got the same problem here.

I also use a zapier subscription… Not really what I expected...Nice UI but this experience just kills it for me….

Userlevel 7
Badge +8

Hi @Caradhras ,

Sorry you are encountering this error- I know that is frustrating. I have added you to this issue so that you will be notified when there is an update.

Userlevel 2

Same issue here.

I got notified that there was a possible error. When I checked the details I noticed ‘Authorization failed’ so I tried reconnecting the apps. It didn’t work. Each time, I keep getting this ‘rate limit’ reason but I only use this zap 4 times per day with 2,5 hours in between.

This is really an issue because my client is expecting a consistent posting schedule. That’s why I use Zapier in the first place. As a paying customer, I hope to see a fast solution to this problem.

Could you please unmark this thread as ‘Solved’ because it it’s clearly not...

Best regards

Userlevel 7
Badge +8

@PJ_Decoster so sorry you are running into this error! I have added you as an impacted user so that you will receive communication via email with updates. 

Userlevel 1

I am also getting this error. Im only requesting once a day but this error has come up the last 2 days.


Userlevel 1

I am having the exact same issue since two days ago and apparently there is no fix ??

Userlevel 1

I still have this unsolved problem after six months since I created this post. Is there any solution in that topic?

Userlevel 2

Meanwhile, I checked other automation platforms such as and Integromat. doesn’t offer Pinterest integrations at all and Integromat is waiting for approval on their application to the new developer progam.

It seems that the Pinterest API is strongly underdeveloped. Unless Pinterest does some updates, I’m afraid that this is an issue that will keep popping up.


Userlevel 7
Badge +12

I’m sorry that we’re still having this issue with the Pinterest integration. Everyone below, I’ve added you as an affected user on the issue, which means that we’ll send you an email when we have an update:

  • @tinytechtips 
  • @MikaStupnikV1
  • @PJ_Decoster 
  • @zaxarov 
Userlevel 2

@Danvers Thank you for your response. We’ve been told already that a solution for this issue is pending and that we will be informed once there is an update. As @zaxarov mentioned, there hasn’t been any update in 6 months. Which is really frustrating. As paying customers, we deserve to be informed about what is happening.

Could you please clarify which steps exactly have been taken by the Zapier team to find the source of this issue? What are the blocking issues to work on this bug? Why does it take 6 months to be able to come up with a solution?

Userlevel 7
Badge +12

Hi @PJ_Decoster, I completely understand your frustration here and I’ll do my best to address your questions. 


The issue has appeared to have a few different causes as time has gone on. We have monitored a few different measures, including how many users were running into to the same error (which we can see from our logs) and when. 

We have taken some steps to try and remedy the situation, including working with Pinterest to make sure that the Zapier integration is on the most up to date API (that’s the bit of code that lets other apps talk to Pinterest). 

I don’t have an ETA on when we’ll be able to fix this issue, which I know is frustrating and I’m sorry about that. We do know that this issue is having a bigger impact on our users because of the new ‘oh foo’ message that you see when you try to connect your account. 

When we have a fix for this, we will update this thread and any folks who have been added as an affected user on the bug will get an email.