Best answer

Microsoft Dynamics 365 CRM Cannot read property 'find' of undefined

Userlevel 1

Error when reconnecting MS Dynamics CRM:

Zapier could not connect to your account.

Cannot read property 'find' of undefined



Does anyone know what has caused this and how to resolve?
Our connection being down is of massive impact 


kind regards


Best answer by SamB 9 August 2021, 17:02

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

84 replies

Userlevel 1

@Troy Tessalone 


Userlevel 7
Badge +10


Can you show us screenshots of the error message and how you have this step configured in the zap editor.

Userlevel 1

I get this error when connecting to dynamics, not in a specific zap, however two zaps that i have tried to edit since this problem are now offline and cannot be turned on because of this same error

Userlevel 1




Userlevel 7
Badge +14

Hi @EmmaEmergo 

Best to open a ticket with Zapier Support:

Hi, I’m having the same problem, did you find the answer? 

Userlevel 1

We are getting the same Error, both when trying to update a Zap and when trying to reconnect to CRM.

Userlevel 7
Badge +12

Hi everyone

It looks like this is bug that was discovered a couple of days ago. When some users try to connect to Microsoft Dynamics 365, they see the error message Cannot read property 'find' of undefined

@EmmaEmergo, @Yurian and @Carlf, I’m sorry that you’re having this trouble with yourZaps. I’ve added you as affected users on the bug, which lets the team know how many users are having this issue and also means that we’ll send you an email when we have an update. 

We are having the exact same issue. Please add me as well

Please add me to this ticket also. I can’t initiate a new zap with Dynamics 365 as I can’t even connect the account – Help!

@Danvers We are also having this exact issue. The Zaps are not failing however we cannot modify or create new Zaps using the Dynamics App connection.

Please add me to this ticket too. Same error message as you: “Cannot read property 'find' of undefined” and the credentials works as I can login to MS Dynamics directly


I tried to create a ticket but no response yet.

Userlevel 7
Badge +12

@TyFowler, @Adrian_M, @EDV, and @vdelafuente I’ve added you all as affected users on this issue. 


@vdelafuente I’m sorry that you haven’t heard back from the support ticket that you created. I can see that the team did send a response a couple of days ago, could you please search your inbox for ‘’ to double check that the email isn’t in a spam folder/promotions/etc. Thank you!

Please add me to this ticket too. I already created a ticket yesterday and got an response from Zapier Expert “we make future”. I tried to call them but until now I got no callback.

Add me to the list. We’re in a world of hurt until this gets resolved.

Please help me to fix this error as its causing a havoc for us.



Same problem here. We can’t sign in to Microsoft Dynamics 365 CRM during Zap creation. Please add me to the list of affected users. Thanks.

We are having the same issue, please add me

Userlevel 1

Same problem here - since Wednesday, July 14. Filed a ticket, but heard nothing so far.

Userlevel 1

Same issue here. Please add me to the list of affected users!

Same here! Please, add me to the list

Userlevel 1

Please add me to the list.

same problem here

same problem here, please add us to the list

Userlevel 7
Badge +11

Hi @Bravo @|ʙill ⨍elix| @Andrés Proaño @user82929 @moorerm @ITECCO @Andrew May @Bizrahmed @Nathan C @Cibes,

You’ve all been added as affected users. You’ll be notified when this is resolved. So sorry for the trouble this is causing! Rest assured that this issue is of the highest priority. I can’t give an ETA but we’re definitely working on getting this fixed as soon as possible.