Best answer

Issue Adding New Customers into Profitwell

  • 29 September 2020
  • 3 replies

Userlevel 1

I am trying to enter data into Google Sheets, and have Zapier read new data entries from google sheets, and create a new customer in Profitwell


On a new spreadsheet, the first row of data (test Data) works and creates the customer, but after i turn it on, i turn the zap off to enter new data, then turn the zap back on and i get the following error: Subscription pws_yb5I7NEpXlQ3 already exists.


All of the data is different (effective date, value, email) but formatted the same way. Each email is unique, each user alias is unique and it says that the subscription already exists. 


I have tried turning off the zap before adding new data. Tried multiple spreadsheets and data sets. The first entry always sends when the zap is first tested. After that i get that error.


Any help is appreciated!


Best answer by jesse 9 December 2020, 21:54

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +12

Hi @Graham799, could you show us what the Zap editor looks like? The part where you add the information into the fields?


If the information there is typed in, that would explain why the Zap keeps saying that the subscription already exists. 


Another place that you can look is the task history for the Zap: If you look at the information in the Profitwell step, is there different information each time in the task history, or is it trying to add the same information in each time?


Userlevel 1

Hi @Danvers, thank you for replying! The new_add.PNG Attachment is an image that shows you what fields from google sheets are mapped to for Profitwell. You can see that the data is different from the above attachment as the effective date is different, and i can say that the email and user alias is different as well. 


The add_test.PNG image shows the same error message for the data read from a different row. The data is typed in the spreadsheet, and then read and grabbed by Zapier. When I turn the zap on, the zap does not generate a task history. 


I have tried removing the initial customer added in the first test, recreating the spreadsheet with different user entries, and the first test always works, however every record is read as a subscription that already exists.


test_read.PNG shows the data being read from the spreadsheet


Is there any more information I can provide?

Userlevel 7
Badge +9

Hey @Graham799 we just wanted to check in on things here! You’ll likely want to try turning the Zap on, regardless (you can skip the test) and then add a new row to Google Sheets. If a successful Task doesn’t automatically come across to your Task History within 5-15 minutes, you’ll want to reach out to our support team as it sounds like some additional troubleshooting will need to happen here:

Of course, if you do find a solution to the issue you’re running into, we’d love it if you could come back and share how you solved this to help others running into the same issue.