Best answer

Connecting to SQL Server account (Error '08S01')

  • 5 August 2020
  • 7 replies
  • 933 views

Userlevel 1

I checked the documentation on https://zapier.com/help/doc/cant-connect-my-database and nothing seems to help. I have already connected to SQL Server before, but for a different database (or account). When I try to connect again to a new SQL Server account, I get the following error:

 

authentication failed: Could not connect with ‘database user’ and provided password. The response we got from the server is included below for debugging purposes. (pyodbc.Error)(‘08S01’,’[08S01][unixODBC][FreeTDS][SQL Server]Read from the server failed (20004) (SQLDriverConnect)’)

 

I made sure to give the database user of my account ‘read’ permissions to the appropriate database. I know that the version of MS SQL Server I am using is okay, because I have connected Zapier to it before. 

 

Please let me know how to best troubleshoot this. Thanks!

icon

Best answer by Danvers 11 August 2020, 14:56

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +10

@SM-KT have you been able to connect to this SQL server with this username/password before? It appears to be a permissions issue of some kind. Is there a different username/password you can test which has higher permissions to this database/these tables?

Userlevel 1

@PaulKortman I am unsure of the exact username/password as this previous connection was done a year ago by someone else. I have made assumptions based on the users & their roles on the database. I have tried given my current user full control of the server and I still run into the same issues. 

Userlevel 7
Badge +10

@SM-KT do you have access to the zap that was made by someone else a year ago? If so you should be able to copy the settings from that zap to the zap you are working on.

Userlevel 1

@PaulKortman Yes, I do have access to the zap. The problem is that I need to access a different database, therefore I cannot just directly copy the zap. Because I would like to connect to a different database, I need a new SQL Server account (see MSSQL #6 as shown below in Pic1). The one that properly connects to my server is MSSQL #2, though it is to a different database. I unable to see or copy the settings of the successful SQL Server account (see Pic 2) for my new one.

 

Pic1

 

Pic2

Userlevel 7
Badge +10

@SM-KT can you show the settings you are putting into the fields when you are adding the MSSQL account (obfuscate the password and parts of other sensitive information please) there is something wrong in how that is being set up. 

 

Are both of these databases on the same SQL instance? 

Userlevel 1

@PaulKortman I simply just enter my basic information. Of course, with my host, port, etc. As suggested earlier, I have attempted to use an admin user for testing purposes and still run into the same error. 

 

Userlevel 7
Badge +12

Hi there @SM-KT!

If you’re still having trouble connecting your second database to your Zapier account, the first thing to do is to look through this help guide on Common problems with MSSQL. It has a section on dealing with connection issues that might be able to help you here.