Paths "ReferenceError: detailedErrMsg" error

  • 25 February 2022
  • 7 replies

Userlevel 1

I have built a pretty elaborate zapier (proud of myself) with the help of many here. 

It launched, worked beautifully - the record was uploaded to Monday. 

BUT, it for some reason errored (even though everything was executed). 


The logic worked beautifully all the way down to the path. It executed the path I wanted. But I cannot find what the actual error is? It just says

ReferenceError: detailedErrMsg is not defined


What is odd is that the data WAS actually sent to monday and it worked... So not sure what the issue is?

FYI: I have the highest possible version of Zapier and Monday so is not a “plan” issue. 

Any ideas?

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14


What Zap step had the error?

Check the DATA IN for that Zap step.

Click into this Path


Userlevel 1

I did. That’s where I found the error. But I’m not sure what the error is 

Userlevel 7
Badge +11

Hey there, @alexadagostino!

Hmm this is very odd, especially as the item was created in Monday despite it erroring. I did some checking and it seems that we will sometimes see that error in if no subitem column exists on the board. 

Do you think that could be the case here or was a subitem column already present on the board that you’re adding the item to? 

Userlevel 1

@SamB  you are a GENIUS! That is exactly what it was! I by accident threw a subitem. :) 

Userlevel 7
Badge +11

YAY! That’s excellent news, @alexadagostino! I’m so glad that’s all it was. :slight_smile:

I’m having this same issue, not sure what you mean by subitems ? I dont have any subitems on my board

Userlevel 7
Badge +11

Hey there, @Magcaling

I’m so sorry to hear you’re running into the same issue here. That “ReferenceError: detailedErrMsg is not defined” error can sometimes occur when we’re trying to add a subitem to a board where no existing subitem column currently exists. So if you were wanting to add a subitem, a column called Subitem would need to be added to the board first, before a Zap could add subitems to it. You can find out more about subitems in here: The subitems.

Presumably you’re using the Create Item action for Monday and running into that error, correct? If that’s the case, do you have any value currently entered/selected for the Subitem Name field? If so, and you’re not looking to add any subitems to the board then clearing the value for that field should help to get rid of the error.

Hopefully that helps!