My itemized list is stringing together when importing into a Webhook.

  • 14 November 2022
  • 2 replies

Userlevel 1

hi there,


I am using formatter to itemise my list but when i try an import it into a webhook, it’s stringing it together.

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +12

Hi @jordy1234, welcome to the Community!

We might need some extra information/context to help you with this one. When you say that you’re trying to itemise your list, do you mean that you are using the text to line items action?

And could you please share a screenshot of the output of the formatter step ie what you see when you test the step? Don’t forget to remove or obscure any personal or private information in any screenshot you share in the community (eg full name, email address, etc).


Userlevel 1

Hi @Danvers , 


Thanks for your reply. Please see below more detail of my issue.


I am having an issue with my CSV file I am trying to import into webhook.  

When I use formatted to read my file, it seems to output correctly however, when I try and use the output, it is incorrect.


see below:


I have approx 3 heading (code, name, points) and each row under that represents a different person e.g:

  1. 12345,Jane Doe, 50
  2. 16535, Sam Test, 100
  3. 17546, John Doe, 4000


when I look at the output of my test, each row seems to be looking correct.



name- Jane Doe

points- 50



name- Sam Test




code- 17546

name- John Doe 

points- 4000


unfortunately though, when I go and  

 use that information in other apps (such as webhook, it seems to be grouping the columns together in one string. Eg:

Code: 12345,16535,17546

Name: Jane Doe, Sam Test, John Doe

points: 50,100,4000

With this, it’s causing an error as it’s not importing the single item. Also, I tried importing into a database to confirm how it would import into, say, a spreadsheet and it imports the entire string

I have tried each of the settings in formatter, tried to play around with the format of the spreadsheet etc  but nothing 

Wondering if anyone has a solution OR even if there is a way for Zapier to read a file, csv or text without having to use formatter


Thanks in advance