Question

Create "Encoded" POST - Help

  • 9 December 2021
  • 5 replies
  • 510 views

I am unable to POST "encoded".

I put under "content-type" head "application/x-www-form-urlencoded"

I dont think this converts the JAVA to "encoded" before posting.

I want to Post my Zap  but sending the data "encoded"

I look at this URL but could not follow along :( "https://zapier.com/blog/updates/1108/new-formatter-options-encode-urls-and-add-ellipses""

I appreciate any help! I think the use of the header is incorrect as it doesnt seem to be converting the Java to encoded!

 

Jeffrey


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @jprich16 

Please post screenshots with how your Zap step is configured, thanks.

 

Alternatively, you can try opening a ticket with Zapier Support here: https://zapier.com/app/get-help

HI @Troy Tessalone 

 

Thank you for the reply! I did inquire with “help” and they mentioned I should try here.

 

Please see my screen shots - I will not that I was not able to properly follow any help guides so I think my use of the header is wrong since my posts have not been sent “encoded”.

 

 

I have attached two screen shots, one of the JAVA (untouched) and one where I included the header addition.

Thank you so much once again!!

Jeffrey

Userlevel 7
Badge +14

@jprich16 

Can you show the top of Step 4 in a new screenshot? (method/URL)

Can you provide the API documentation you are referencing for how to send your request?

@Troy Tessalone of course

it’s to a salesforce crm is that help

also! when i tried it using a chrome extention plugin called “postman” i was able to test send uses the urlencoded tab!

 

does this help?

 

THANKS AGAIN SO MUCH!

 

Jeffrey

@Troy Tessalone

 

Do you want more screenshot or info, just ask!!