Question

Authorization Error on GET request from ClickMagick

  • 4 February 2024
  • 6 replies
  • 32 views

 Hey everyone,

I have been having trouble with a GET request in Zapier.


The zap creates an Ad Report in ClickMagick and then sends that report to Monday. I keep getting a 404 on the third webhook in the zap. Picture attached.

What is stumping me is I am getting an auth error when the first 2 webhooks have the same authorization criteria and they are executing fine. Any insights on what could be causing this?

 

I should also mention that the Webhook has been working fine for 2 months and this suddenly started today.

 

I appreciate it. Thank you

 

 


6 replies

Userlevel 7
Badge +14

Hi @jimmykelly.io 

We would need to see screenshots with how your Zap step is configured for context, thanks.

@Troy Tessalone thank you. Updated the original post with the screenshot. 

Userlevel 7
Badge +14

@jimmykelly.io 

The screenshot is tiny and fuzzy, so we’re unable to see the details of the webhook Zap step.

 

ClickMagick Status page doesn’t show any ongoing/recent incidents: https://www.clickmagickstatus.com/

@Troy Tessalone sorry about that. Are these better?

 

 

Userlevel 7
Badge +14

@jimmykelly.io 

API docs to reference: https://api.clickmagick.com/docs/#operation/getCampaignStatsReport

 

https://api.clickmagick.com/v1/campaigns/projects/stats/reports/{report_id}

curl -X GET -H "X-APIKEY: YOURAPIKEY" https://api.clickmagick.com/v1/campaigns/projects/stats/reports/3752921

 

Try removing this Query String Parameter since the Report ID is passed in the URL path

 

Try removing this Header

 

Userlevel 7
Badge +14

@jimmykelly.io 

Also, if you are trying to create a report then get the report right after, you may need to add a Delay (For) step between.

 

Reply