Problems with jotform connect

Hi, I have tried updating my zaps to the new jotform version, as required. However, since I touched the zaps they no longer work (since yesterday, when they should have still been working with the old version, I guess).


When I try to fumble my way through how to do this update I have done following: found the big blue update button, pushed it twice, reselected new submission as trigger, when asked to reconnect done this step a million times (yes, exaggeration), when this led to an error, I tried the reconnecting link above (to no avail), I tried to add connections from the connections tab (reconnect, test, add new connection - all of it failed with error messages.


Since I also looked into jotform and jotfrom says that the connection is green, I no longer know what to do.


Please help.

7 replies

Userlevel 7
Badge +14

Hi @VicMa 

For us to have more context, post screenshots with how your Zap steps are outlined and configured for each tab section in the Zap step along with any encountered errors.

Help article about how to update a Zap app in a Zap step:

Userlevel 1


I have exactly the same problem.

I attempted a reconnection but without success.

However, Zapier redirects to a JotForm window, and I follow the steps to perform the reconnection.

But it does not work despite several attempts.

How should I proceed?

Thank you

Userlevel 7
Badge +11

Hi folks 👋

@VicMa and @JYP - sorry to hear of the troubles with the JotForm app here. I’ve just tried to recreate this on my end by adding new and reconnecting existing JotForm accounts and was unable to produce any errors. My Zap is running the latest version of the JotForm app, so I wonder if the upgrade that took place right before reconnecting is causing some sort of glitch here. 🤔

Can you both try reconnecting your JotForm accounts directly from the My apps section of your Zapier account, instead of doing it within the Zap. You can view your Jotform account connections and reconnect them here:

Keen to get to the bottom of this so please keep us updated on how that goes!

Userlevel 1


Thanks for your return.

Just tried again a few minutes ago and it works.

I just check “Yes” in the Jotform window that the server are in EU and not in the US.

I’m a french user.

See you.


Userlevel 7
Badge +11

Thanks for letting us know @JYP. I’m so pleased to hear that selecting the EU server when reconnecting your Jotform account resolved things for you here! 😁🎉

@VicMa - are you also using JotForms European servers? If so can you try selecting the EU server when reconnecting as JYP mentioned, to see if that resolves things for you too?

Looking forward to hearing from you on this!

Hi @SamB @Troy Tessalone , we have the same issue and have tried the above but it isn’t working our ticket number  is 1947811 but no one has got back to us please can this ben looked at as a matter of urgency? Thanks 


Userlevel 7
Badge +11

Hi there, @NAAMA 👋

I had a look into the ticket you referenced and can see that Support has since got back to you. It appears that following the recent changes that JotForm made to their app on Zapier, it’s now expected that form submissions created via JotForm’s API instead of embedded forms would no longer trigger a Zap.

Not sure if you’ve seen Support’s reply yet but they’re going to submit a feature request on your behalf to have support for submissions created via the API to trigger the Zap added again. If you have any follow up questions on that it would be best to continue the conversation with them on the Support ticket directly.

In the meantime, as you’re using JotForm’s API to create the submissions perhaps you could also use it to send a webhook to a Zap to trigger it? Webhooks by Zapier has a Catch Hook trigger that generates a unique Webhook URL, so I’m thinking that if you can also send the submissions to that URL it will trigger the the Zap and allow you to carry out the desired actions as necessary. You can learn more about this here: Trigger Zaps from webhooks

Hope that helps! 🤞