“path/no_write_permission/...” Errors when creating a folder in Dropbox

Userlevel 1

This post was split from the topic: 

@jarednw this is super helpful. I faced the same problem and was able to get the root namespace ID, but I’m struggling with an error. Zapier’s returning “path/no_write_permission/...” when I try to use it to create a folder in Dropbox. I’m a Team Admin in Dropbox, so my account should have every permission.


and @SamB  just flagging that Team Folders are still not selectable as a dropdown function. This workaround seems to make the connection, I just don’t have write permission for some reason.

any insights or recommendations would be super helpful. thank you!

24 replies

Userlevel 2

@ktownsend are you trying to create a root folder? or a new subfolder in an already existing folder? I think subfolder should work but a new root folder in a team space requires a different API endpoint

Userlevel 1

@jarednw a new subfolder. My org transitioned us to a Team Folder and I’m trying to adapt a Zap that used the Dropbox “Create Folder” action. So the action would create a subfolder, but uses the root id workaround since my Personal folder is the only one selectable within Zapier. The workaround seems to successfully call the API, but then reject the Zap on a permissions basis. (Thanks for your help btw!)

Userlevel 2

@ktownsend hmm, I'm not sure because that functionality works for me. Did you try creating a new dropbox connection with Zapier, maybe it’s using an old version of the integration?


Also just as a tip, I hardly ever use the create a folder anymore because it's a redundant step. If you use upload file for example and just enter a custom path like: /Top Folder/NextFolder/NewFolder/NewFolder2 then it will auto create NewFolder and/or NewFolder2 if 1 or both aren’t already there when it uploads the file.

Userlevel 7
Badge +11

Hi @ktownsend and @jarednw! 👋 

@ktownsend - hope you don’t mind but I’ve moved your posts here out into a new topic since you appear to be running into a permissions based error which is different from the issue discussed in the other post.

I’ve done some digging and found that there’s a bug report open that relates to these “no_permission” errors so I’ve gone ahead and added you to that. I can’t make any promises around when this issue will be resolved by but we’ll be in touch via email as soon as it’s been fixed. 

Thanks for your patience in the meantime!

Userlevel 7
Badge +11

Hey folks, 

Good news - the bug report has been closed! 😁🎉

The errors appear to have been related to a recent incident on Dropbox’s end which has since been resolved.

@ktownsend - can you double-check your Dropbox related Zaps again now and confirm whether it’s fully resolved?

Userlevel 1

Hi @SamB Just checked and I’m still getting the error. The only space that appears on my Dropbox is “Personal Space” and not the new Team Folder that Dropbox switched me to. So I’m trying to manually access that space with the ten-digit ID I found for the Team Folder via the API. But it gives me a permission error if I try to use it.

I have the same issue. same error message: 

Failed to create a folder in Dropbox


I am not able to run my zaps……….. this is a problem and causes much work for us.

Userlevel 7
Badge +6

Hi @ktownsend and @Perzi,

Have you tried reconnecting your Dropbox account and see if it’ll run into the same issue?

I'll be keeping an eye out for your response!

What is “re-connecting the dropbox account” exactly?

I have opened the zap and re-acccepted all steps and connections. but test trigger to create a folder fails inside the “edit mode”.


Userlevel 7
Badge +6

Hi @Perzi,

You can either reconnect the existing account or delete it and create a new connection in the “Apps” page. Here’s our help article on how to do that:

If reconnecting the account doesn’t work. You might not have access to the team space.

Here are a few things to note:

Users can only access files within their root folders (folder with the name displayed as / ). If you're added to a Team directory that is configured as a Team Space, then you should be able to access folders/files in that directory by updating the Spaces option in the step.

Not all Team directories are configured as "Team Spaces". Team Spaces config is what Dropbox recommends, but Teams can still configure their directory in the "old" way (this is called a Team Folder configuration).

Please check if you're added to the Team Spaces directory.

Here's an indicator in Dropbox UI that the user's team folder is not configured for "Team Spaces": Ex1 | Ex2

Hopefully, this helps.

Hi ken.a 

I followed the steps. and Reconnected the Dropbox app. I received the popup and allowed zapier access to Dropbox. 
Also I am working as a Dropbox Admin daily, so I am aware about Team folders and access.
The Zap has worked previously, and nothing was changed from our side in Dropbox!! 

Still the zap won't work now, and I receive the same error.

Userlevel 1

Yep, disconnected and reconnected Dropbox entirely but still the same error.

Hello….. is there anyone doing something about this issue? You charge us on time every month. That is something which seems to work flawlessly. But you have offered a service which you do not deliver. 
so please give us an update how youre going to solve this. 
thank you. 

Userlevel 7
Badge +6

Hi @ktownsend and @Perzi,

I’m so sorry for the inconvenience this has caused you. I did more digging and it seems like this was related to this Dropbox Incident: which now has been resolved.

Could you please try these for me?

  1. Delete the existing Dropbox connection.
  2. Create a new Dropbox connection.
  3. Re-create the Zap.

Again, I’m really sorry for the inconvenience here. I appreciate your patience and understanding.

Userlevel 1

Hi, all. Piling on here. Having exactly the same issue. Everything worked in my Zaps until about April 26 when I started getting the path/no_write_permission error on Dropbox actions. I am now unable to select my team spaces from my dropbox account when editing/creating Dropbox Zap actions.

@ken.a I tried the steps you suggested at approximately 7:00 AM EDT on May 7 (thankfully it’s a simple zap) but still unable to see the team spaces.

Not working at all.


I am a bit tired of doing your Q&A and testing. maybe you can take this issue seriously and test it and then come back to us when its done.

Userlevel 7
Badge +6

Hey @Brandon-Generis and @Perzi,

Thanks for sticking with us while we sort this out.

I'm really sorry if it seems like I'm not taking this seriously. I'm doing the best I can with the limited tools I have, but I'm unfortunately coming up a bit short here.

For this reason, I'd recommend reaching out to our Support Team because they have more advanced tools to dig deeper into this problem. They can look at the Zap and its logs and figure out what's going wrong.

You can reach our Support Team here: 

Really appreciate your understanding and patience with this.

Thank you kena. I thought you are part of the support team. 

Userlevel 1

Kudos,  @ken.a. I appreciate the attempt. Will reach out to the support channel now.

Same issue here. Dropbox portion of Zap stopped working in late April. Information from Support not helpful. Other suggestions?

Userlevel 1

Getting the same “no_permission/” error after reconnecting and checking everything. Any suggestions are appreciated here too

Userlevel 7
Badge +6

Hi @josh.barrett and @Get Level Best,

I recommend reaching out to our Support Team regarding this issue, as the bug has been closed. Please inform them that you’re still experiencing the bug so that they can take another look at this issue.

You can contact our Support Team here:

I appreciate your patience and understanding.

Any updates?

Userlevel 7
Badge +6

Hi @Dr Al,

It seems like the issue has been resolved. If you're still experiencing the same problem, I suggest getting in touch with our Support Team. They have the necessary tools to examine your Zap and its logs more closely.

You can reach our Support Team here: