Gravity Form to Google Sheet

  • 3 March 2022
  • 1 reply

My zaps from Gravity Forms to Google Sheets no longer works. It pulls and sends tests just fine, but when I test the actual form, nothing appears. 

The zap has worked in the past, with plenty of issues to troubleshoot along the way, but it worked. 

I’ve reconnected my gravity forms. I’ve reconnected the google sheets. I’ve gone through each of the new fields required and made sure everything was accurate. I’ve deactivated cloudflare. The only thing I haven’t done is deleted the zap and start from scratch (which will take a lot of time and I’d rather not deal with zapier than rebuild my zaps).

I’m sincerely at a loss as to why my form submissions are not going through to google sheets.

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +14

Hi @hannahberg 

Here’s a workaround you can try…

Use the GF Webhooks Add-On instead:

The Zap trigger would be Webhook - Catch Hook: