Best answer

Google Drive Convert to PDF doesn't work (worked for months, now suddenly stopped today)

Userlevel 2



I’ve build an automation a few months ago which worked just fine. This morning I started getting error messages:

What seems to be causing the error is a file, which I create as a doc. When I try to do anything with the PDF version, I get an error. Anyone know's a fix?



Best answer by nicksimard 5 May 2021, 21:16

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +10

@Frisse Blikken 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 1

Just jumping in here, I echo this problem. Getting the same issue trying to upload the Google PDF to Dropbox. I get a bad request in Dropbox because of the file coming from Google Drive as a PDF

Userlevel 7
Badge +10


I’ve had it on some of my zaps today - so I reckon it might be a sitewide issue. Let’s hope it get’s resolved soon!

Userlevel 7
Badge +11

Hi @OIMBobby @Frisse Blikken and @AndrewJDavison_Luhhu!

This appears to be a recent change/new requirement on Google's end, and our engineers are investigating this further.
In the meantime, can you take a look within your Google Drive account to make sure that the file or folder's sharing permissions is set to "anyone with the link can view"?

This should resolve this error, and I expect you should be able to replay the errored Zap Runs to verify that it's working after making that change.

Here's more information on replaying failed Zap steps:

NOTE: For anyone else experiencing this issue, please let us know here and/or get in touch with our Support team so we can add you as an affected user.

Userlevel 2

Hey guys,

Thanks for the comments. The above fix works, but is not very secure since the documents are publicly available. I found a workaround using a temp. free to use application (ConvertAPI). I hope I can use it till they found a fix..