Best answer

Forminator > Salesforce

  • 27 March 2020
  • 3 replies

We ran a couple more test on the system and I stand corrected regarding my previous observation. I was able to make the “Lead” work without any issue, by filling up the required fields.

So I exported your Form and configured that with Zap and that also worked fine in my system. However, I could notice once I add the “Email” it threw an error when tested and gave the following error:

However, the error message what you see is caused due to more than one fields having issues. Since I’m not able to replicate the exact error it’s tough to say which exact field it is.

I also brought this into our developer’s attention and what Forminator does is just pass data to Zapier and then Zapier connects to Salesforce integration.

This seems more specific regarding an issue within Zapier and Salesforce integration. I’m afraid it could be within Zapier or a setting in Salesforce causing an issue.

To start with would recommend you getting in touch with Zapier support to see what exactly is causing such an error to occur as the fields from the Forminator should have worked fine form your given screenshot.

Please do let us know what Zapier support has to say regarding this so that we could check further if needed.


Best answer by Danvers 20 April 2020, 15:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +12

Hi @Community It looks like the error happened because the value that was being sent in email field for the test data wasn’t a valid email address. 


In the screenshot, you can see that it says ‘Email: invalid email address: Email address’ 


That means that Zapier sent the value ‘Email address’ to Salesforce and Salesforce rejected it because it expected the information to look like an email address (eg It looks like this is happening because the test information in the Zap (probably from the trigger) is just test data, rather than an actual sample. If that’s the case, then as long as valid email is sent to Salesforce when the Zap is turned on, it should work. 


Could you give that a go and see if works in the way that you need? 

Able to make it work but the email field continues to fail.  Ideally I’d like to know/understand how to sync with email as that is vitally important to automate/sync every entry.  Any insights helpful.

Userlevel 7
Badge +11

Hi there!

I know that around the time of your original post there were some changes being made to the Salesforce integration, which may have contributed to the errors you were seeing. Are you still running into these problems? If so, can you elaborate a bit on how your Zap is set up (which action you’re using, which fields are showing as having errors, etc.)? Thanks!